Addons Not Loading from /addons

Never thought I would have to make a thread on Help and Support again, but oh well.

Anyways,
I’ve been trying to Install GM13 (addon.txt) Addons into my /garrysmod/addons folder, But for some reason they won’t load. From what I see it’s a bug on Mac OS X. I have attempted to install Wiremod ATM.

Hope you can help.

System:
Hardware Overview:

Model Name: iMac
Model Identifier: iMac8,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 6 MB
Memory: 3 GB
Bus Speed: 1.07 GHz
Boot ROM Version: IM81.00C1.B00
SMC Version (system): 1.29f1
Serial Number (system): VM835GF8ZE2
Hardware UUID: 5ADDAD38-F000-596B-8FED-D245801A9EBE

Ethernet:

Type: Ethernet
Hardware: Ethernet
BSD Device Name: en0
IPv4 Addresses: 192.168.1.78
IPv4:
Addresses: 192.168.1.78
Configuration Method: DHCP
Interface Name: en0
Network Signature: IPv4.Router=192.168.1.254;IPv4.RouterHardwareAddress=3c:81:d8:5f:34:f0
Router: 192.168.1.254
Subnet Masks: 255.255.255.0
IPv6:
Configuration Method: Automatic
DNS:
Domain Name: home
Server Addresses: 192.168.1.254
DHCP Server Responses:
Domain Name: home
Domain Name Servers: 192.168.1.254
Lease Duration (seconds): 0
DHCP Message Type: 0x05
Routers: 192.168.1.254
Server Identifier: 192.168.1.254
Subnet Mask: 255.255.255.0
Ethernet:
MAC Address: 00:22:41:30:ce:02
Media Options: Full Duplex, Flow Control
Media Subtype: 100baseTX
Proxies:
Exceptions List: *.local, 169.254/16
FTP Passive Mode: Yes
HTTP Proxy Enabled: No
HTTP Proxy Port: 80
HTTP Proxy Server: 122.72.33.139
HTTPS Proxy Enabled: No
HTTPS Proxy Port: 8080
HTTPS Proxy Server: 205.213.195.70
Service Order: 2

System Software Overview:

System Version: Mac OS X 10.7.4 (11E53)
Kernel Version: Darwin 11.4.0
Boot Volume: Makintish
Boot Mode: Normal
Computer Name: Liam Newman’s iMac
User Name: Liam Newman (lobby)
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: Yes
Time since boot: 6:22

One more thing:
I have tried loading the addon both extracted, and compressed.
Just letting you lot know.

I also have a similar problem, trying to load -tickrate enabler
( http://didrole.com/tickrate_enabler/ )
I tested on a fixed debian wheezy server and also windows 2008 vps, with no results.

It may be a problem globally with loading addons afaik

I just posted a support thread on support.facepunchstudios.com. Hopefully that will help.

Macs CANNOT load legacy addons. period. you just need to wait. it sucks, i’m waiting too, because we are the minority, don’t expect it to be soon.