Addons won't show.

Specs: Windows XP Professional
Processor: Intel® Pentium® 4CPU 3.00 GHz
RAM: 2 GB
Video Card:NVIDIA GeForce FX 5200

Addons:
To lazy to list, picture instead,

Gamemodes:
Dark RP
Gang Wars RP
Dark RP HG
1942 RP
GOLRP

I don’t know what to do, since I haven’t found a good fix in the forums. When I add any addons, I can’t find them in, say, the tools area, or for models, the spawn menu. I have things like PCMod2, NPC Control, NPC Spawn Plates, WireMod, and SCars. I put them all in addons, since they have info.txt. Anyone know why? No picture for the menu, they just won’t show up at all. Thanks.

Again, no one seems to help me, even though everyone else gets a reply within the first few hours… to say it in laymen’s terms:

I download addons.
I put in addon folder (readme.txt tells me to).
I make sure there isn’t an addon/addon/ETCMOD, since that is being retarded.
There is a info.txt in there, I read it, it goes like this:
“AddonInfo”
{
“name” “SmartSnap”
“version” “0.9.5”
“up_date” “”
“author_name” “Syranide”
“author_email” “public@syranide.com
“author_url” “http://www.syranide.com
“info” “A seamless tool for placing objects with pinpoint accuracy”
“override” “0”
}
That is smartsnap, one I just got.
Everything is in the order is should, it has always worked in the past.
Nothing shows. I had a few addons before, like wiremod, now it doesn’t show. They disappeared.
I’m stuck. Garry’s Mod (or Valve being a pile of cr…) has won. Anyone want to kick there .lua ass?

You can’t find the tools menu or does the addons doesn’t appear on the tools menu?

If I were to say, install Wire Mod (like I did months ago) correctly, (which I did, since it DID work) it would show up as another tab on the side, past options and admin crap. Or, if I installed some tool, like NPC Control, it would show up under tools like Render and Constraint, or if it was a model, it would show under it’s drop box, like General Construction or Half Life 2 Vehicles, but I have all 3 of these kinds, and non do what I wrote. I can get a quick screenshot, but it would show a normal, vanilla Gmod. Also, I just installed a mod from garrysmod.org to make explosions not be smokey, and it just does normal things. Also, gamemodes work when I go on a SERVER with it. I can’t, say, play it SP by changing the gamemode under options. Thanks.

Have you tried reinstalling or update your svn.
Plus gamemodes go to the gamemodes folders not the addons

Ok, that was lovely. No offence, but that was a fail. IF you read what I say, my SVN’s and such are updated ( not stated directly, but its obvious), and my mods are made for the newest GMod. They have ALWAYS (really always) worked in the past. But suddenly, they don’t work. NO offense, but your newest post sucked. I mean not to be a jerk, flame, etc. But if you don’t know, can you ask someone who might know? But your first post did help a bit so I could explain more. Thank you for the first.

Sorry I didn’t had any suggesting, plus I ask a question to make sure but you were like “lol wat a fail”(no offence) and didn’t give yes or no (assuming you did). Go to extinction in the menu to make sure the addons are there. If there not there, then Garry’s Mod is forcing to vanilla somehow.

Ok, nice post, minus some grammar (don’t worry, I fail grammatically often, P.S., if you use FireFox, and highlight then rightclick, auto spell check!). I’ve checked before, nope, no extensions in add-ons but some other games, like CS:S, Portal, Free. No add-ons in my folder. Anyone else have any ideas?

Rename the garrysmod folder (the second one) to “garrysmod old” Start the game and it well create a new one. Put your addons and gamemodes to the new one and see if it works.

I should have thought of that. Let me go try it. Thanks.