[ Advanced Duplicator 2] Saving hangs for a long time and gives 'File contains EOF errors' message

I’m trying to add advdup2 to my server, and the saving part is EXTRA slow, like takes like 5min to save 1 prop, and then it gives this error:
addons/advanced_duplicator_2_773402917/lua/advdupe2/sh_codec.lua:366: File could not be decompressed.[AdvDupe2Notify]DEBUG CHECK: File contains EOF errors.
I tried to add the github version and the workshop version too, I also tried to delete it from data folder before reinstalling. I have even tried to remove my sv.db file and try it like that.
thanks for the help!

I don’t know what your particular issue is, but considering your GitHub issue and this thread haven’t received any responses, might as well try to help.

Assuming you’re on a Windows machine, are you by any chance using the c++ module, gmsv_ad2filestream_win32.dll, that (used) to have a compiled version available for download? If not, it may be worth trying out to see if it helps.

Someone else recently asked for a compiled version since the old links have apparently gone dead.
I uploaded it, so if you want to give it a try, read here: http://forum.facepunch.com/showthread.php?t=1136597&p=51368377&viewfull=1#post51368377
I haven’t modified it in any way, but if you do not trust me, you can also compile it yourself from their source: https://github.com/wiremod/advdupe2-native/blob/master/ad2filestream.cpp

Either way, once you have it, put it in your server’s garrysmod/garrysmod/lua/bin folder (create /bin/ if needed) and restart the server with AdvDupe2 to load the module.

To explain, at least in the older days, the c++ module was supposed to help when saving files. Whether that’s absolutely still true, I don’t know, but they still have the check in place and load it if it’s available: https://github.com/wiremod/advdupe2/blob/1c39b8ed0eb417a183f9ea45eda9b92faad74f31/lua/advdupe2/sh_codec.lua#L12-L23

Thank you for your reply ! but my server is runing on linux debian 8 !

Loading from advdupe 2 works fine, the problem only appears when trying to save stuff