Advanced Duplicator 2 Saving Lua Erorrs

When I try to save anything using the Advanced Duplicator 2 tool I get this error. It’s new and started sometime in the past couple days. I had a player exploit money and give everyone $INF as their money somehow so it started after that. I’m not sure what causes it because I did too many things to trace my steps.

[ERROR] addons/advdupe2-master/lua/advdupe2/sh_codec.lua:446: attempt to index local ‘encodedDupe’ (a nil value)

  1. Decode - addons/advdupe2-master/lua/advdupe2/sh_codec.lua:446
  2. func - addons/advdupe2-master/lua/advdupe2/cl_networking.lua:62
    3. unknown - lua/includes/modules/net.lua:32

did you recently add QAC or anyother anti cheat addon? that usually screws up advanced dupe 2 for some reason because it always had for me.

I did add QAC so that’s likely the issue but I also had this same error when I tried to edit my database so I’m not sure. I can remove QAC but I need some kind of anticheat on my server and LeyAC doesn’t like my server very much.

Well I can’t think of any other anti cheats so if you can’t find another, I just recommend disallowing client side scripts, turning sv_allowupload and sv_allowdownload to 0, and putting your rcon password in the command line instead of in the server.cfg file. If your host doesn’t allow you to edit the command line, surely they will do it for you if you ask.