alarm loops after trigger despite stop trigger

when the door starts to close it sets off an alarm. however, i want the alarm to stop playing when the door is fully closed. for some reason the alarm ignores this and plays forever.

here are the outputs of the door

as an alternate solution, considered hooking up a stopsound tied to the onclose event with the delay for however long the door takes to fully close?

Well that are looping sounds in Source for ya.

Be sure to uncheck “Is not looped” flag in ambient_generic.

Send output “volume” with 0 parameter.
It’s not perfect but it works.

edit.
I have oher solution - make the same, invisible, non-solid doors with alarm sound as closing sound.

still nothing :confused: anything else i could try?

Did you tried that invisible door solution? Put an alarm sound in that door instead of ambient generic.
Set it as ‘moving sound’. It has to work that way, because doors use looping sounds with no problem.

that does work yes but i need the alarm sound to play throughout the entire map and last time i checked func_doors dont have a setting to do that.

Since its not working, an alternative would be

OnFullyClosed

alarm

Volume

0

can you not make the door a func_movelinear and set the play move sound and play stop sound on the func_movelinear ??

Make sure the sound file you are using has looping points.
More importantly is to uncheck the “is NOT looped” flag of the ambient_generic. If this is checked on a looped file, you cannot control the sound anymore once it’s started.

update:

ok so it doesnt work with any looping/custom sound files. i just tried it with different sounds. if its something like the overwatch voice it does as i told it but if its an alarm sound (any looping sound) it goes on forever.

weird, peculiar, and annoying all at once.

thanks hammer <3

[editline]11th May 2016[/editline]

thanks for all your help though. i appreciate it.