Alien Swarm Help Needed

I got a few problems:

  1. Whenever i run my map, in the correct directory (user/common/swarm/swarm/maps), nothing happens after the map has compiled, and going in-game and trying to launch it shows nothing

  2. i cant find the entity to start a “swarm” as it were, to make aliens constantly spawn and attack

Post in the question mega thread(s) next time.

[editline]01:47PM[/editline]

Should be what you want.

ah, sorry

[editline]07:47PM[/editline]

and that link doesn’t explain why my maps wont open

Can you tell me what you did from step 1 to the end.

Ok

i opened the editor and made a basic map, contained it in a brush and named it “seal” or something that the wiki said, added four spawns and ran it

did i miss something?

Any errors in the compile log?

i didn’t see the compile log, this one closes itself off

Go to
C:\Program Files\Steam\steamapps\common\alien swarm\sdk_content\mapsrc
And copy and paste the .txt file for your map.

Use code tags please.

there isn’t one there…

Did you even compile?

Tell me if you did this.

Opened alien swarm, did sv_cheats 1, tilegen, made the map, exported the .vmf, opened hammer, edited it, compiled, ran it through alien swarm.

all thought i just found a way to stop the log from closing, says that there is a .PRT file missing?

I didn’t use the tile editor, all from hammer

Did you compile with Final-HDR

No, one second

[editline]08:36PM[/editline]

still says that a .PRT file is missing

ah, i had this exact same problem. i can’t remember excatly what id id other then cordon off the map and making sure the box is hollow.

When compiling, it will always say that there’s a leak, due to the new way Alien Swarm seals its maps.

Try saving to your alien swarm/swarm/maps folder, and then compiling. Run the game and type in “map yourmaphere.bsp”

the level box is hollowed, but not cordoned

tried that, there was no such map, but when i go to the map folder, it’s there

it doesn’t need .bsp at the end so it would just be

one sec, i will cordon it

[editline]11:14AM[/editline]

And now it runs and opens by itself, I guess it needs to be cordoned