All the tools is acting like the camera tool.

It’s quite hard to explain, and I’m tired, but anyway;
Simply, nothing works. When I click the brush tool, and I move the cursor over the “Top” camera view, it doesn’t create a block. It just moves the view across the grid. What the fuck?

Edit:
Err… It like… Fixed itself…

Edit:

What’s up with the “Awful spelling” rating?

I’ve had that happen to me few times…

VALVe better fix it. Annoying as hell. I’ve had it before, was a long time ago, and I solved it by restarting STEAM, but this time that wouldn’t work. And then, it randomly starts working again.

Whenever this happens to me I just send a steam message to anyone on my friends list and it works normal again.

Press space.

Space sometimes fixes it, but usually i just restart the pc.

This. Hitting space while Hammer is in the foreground should fix it - restarts shouldn’t be necessary.

Also when the camera is moving without you doing anything; File - open - cancel.

I don’t understand how stuff does that sometimes, like, it crashes or breaks somehow, and even ending the process and making sure it has no memory addresses left in use it still doesn’t work on launch, but a restart fixes it…?