Alyx Face Texture

Hi!!

I have strange problem with texture…

http://img402.imageshack.us/img402/8407/alyx.png

My step:

-Decompiled Alyx
-Add a new line to mdldecompiler.qc

$includemodel “humans/umpa_female.mdl”

under $includemodel “humans/female_ss.mdl”

like this


$includemodel “alyx_animations.mdl”
$includemodel “alyx_postures.mdl”
$includemodel “alyx_gestures.mdl”
$includemodel “humans/female_shared.mdl”
$includemodel “humans/female_ss.mdl”
$includemodel “humans/umpa_female.mdl”
$surfaceprop “flesh”


-Compile with GuistudioMDL and put all file in half-life 2\Hl2\Human

Someone can help me?

I don’t know what you did but you should make that your avatar. Picture of close-up on face, please.

Try compiling without adding anything to the .qc. The decompiler may not be able to decompile the model correctly. Is it the Ep2 version?

I think is version from source 2007 shared models.gcf

Maybe a conflict for different alyx version?

Sorry for bad english I’m Italian.

I’m surprised issue is still, well, an issue. Problem is the UV map needs to be moved back onto the texture. Decompiling shifts the all the UV maps down by the exact length of the image. Normally it’s not really a problem, since it’s still technically lined up (since the texture technically tiles forever), but for some reason face textures take issue with this. The problem can be resolved by importing the SMD into any model editing software with a UV coordinate grid editor, and simply moving the entire face UV back up.

I remember this has something to do with her hair/headband.

[editline]asdsagf[/editline]

Or not.

But strange issue.

I want add only my custom animation in Alyx model…

this :

$includemodel “humans/umpa_female.mdl”

Yes, but decompiling the model causes an issue with the reference file.

I understand… I think I can try other alyx model from this site.

I tryed with sheva model and no problem…

http://joeljamescomedy.com/wp-content/uploads/2009/09/robocop_l.jpg

“I think the face looks fine.”

Basically, you’re using her Source 2006 model. Those textures are meant for Source 2007 Alyx

Sure it’s not the same issues as the wooden citizen heads?
Have you tried unchecking (or checking) clamp s and t on the vtf?

But in GuistudioMDL?? Sorry I’m a noob…

a) I recommend you stop using guistudiomdl.
Second - no - what you do is unpack the textures for the model, put them into a newfolder and change the respective filepaths in the QC and VMT files (cd materials) once that is done you recompile the model and open the VTF in vtfedit for instance. There you will have an option to change the clamps.

Thanks!! I uncheck the clamp an clamp T with vtf edit and now work fine…