Am I doing this right?

From what I’ve read online, I think I’m doing this right. Correct me if I’m wrong. When attempting to start an internet server, I:

  1. Start Gmod.
  2. Create Multiplayer
  3. Choose Construct
  4. Make sure that “Local Network Game” in the options tab is UNCHECKED.
  5. Max out the sandbox settings to 200, for maximum fun.

-The game loads-

From my console, I:
ip <my ip address that I’m not telling you guys>
sv_lan 0
heartbeat

Yet, my server still does not show up on the list, and my friends cannot join, from Steam, or otherwise.

It lists me as LAN, with my local IP, no matter what I do.
Yes I have my ports forwarded, btw.

What am I doing wrong?

We’re not 4chan we won’t hack you.

Make sure you give your friends your external IP Address to connect from. Try getting a friend to type “connect <external IP>” in their console and attempt to join your game. If this does not work, double check your router’s settings, and make sure your ISP allows UDP connections to the port 27015.

A server on your computer will never appear in the Internet tab of the server browser. Ever.

Obviously not.

You need to use the SRCDS for GMOD, which is downloadable from STEAM, then you can run the file with the GMOD install launch, which can be found on the Wiki.

Mine does… Your argument is invalid.

If you are using DHCP (The thing that hands out IP addresses) on your network then you could be assigned a different IP address to the one that you port forwarded to. To solve this you need to assign your PC a static IP and then port forward to that IP.

Thank you, everyone for helping me with my little issue, I figured out my problem, and it was kinda dumb.

  1. When I was forwarding my ports, I updated my router, which reset my local IP addresses, making my forwarded ports completely wrong.

  2. The server I was running in the first place was perfectly fine, my stupid mistake, was, I wasn’t giving Derek my port. I was giving him ###.###.#.#, when I should have been giving him ###.###.#.#:#####.

Thanks again, we had lots of fun last night dicking around on gm_construct.

Rymar

Uh, yeah, they do. You just have to have your ports forwarded correctly.

Then something is SERIOUSLY fucked up somewhere.

Because when I run a TF2 srcds, it does NOT show up in the Internet tab for me, yet people can come and go on it as they damn well please. Pubbers, even.

blah listen servers…
maybe good for a lan party of 2 - 4 people but sucks for online connects.

to connect to your own server you will connect to the local IP or lan IP (192.168.x.x), anyone else outside of your LAN would use your external IP
as for it showing up in the browser, it depends on port forwarding and so on.

If you just want to play with friends, you could try setting up a Hamachi network (which in case you don’t know, sets up a connection between computers which mimics that of LAN, allowing you to set up private game servers).

It worked for me and i hosted myself and a friend on private sandbox.

Also you don’t need to have forwarded ports for Hamachi (just in case yours are done wrong or whatever) because the private connection overrules the port protection.