Amazing Computer, but Graphics are Occasionally Terrible

I have an amazing computer. I can play GTA 4 on it’s hishest settings and I will be able to play Battlefield 4 on it’s highest settings, but occasionally, when I’m playing TTT on Garry’s Mod (also on it’s highest settings) my graphics randomly deteriorate. Guns that looked real 5 minutes ago look like plastic toys. When I restart Garry’s Mod my graphics go back to their normaly very high quality. What is causing my graphics to randomly deteriorate, and how do I keep my graphics the way they I set them?

Send me a picture of your graphics options, might be a DirectX problem. Also, have you started up CS:S in the past month or so?

I’ll just post it here for now.

http://cloud-2.steampowered.com/ugc/615021602296014664/1145A825D8DAC57533D3F8A48C58958CE7027562/

Sorry if it is a little big. I couldn’t change the size.

Right click Garry’s Mod in your steam library, go into the properties, and find the launch options. Once you’re in there, put “-dxlevel 95” without the quotation marks. Press Ok, and start the game again. Your hardware DirectX level should be v9.0+ now.

Do that.

Also, for the future, to make the picture smaller, use
tags instead of [img] tags.

[thumb]http://cloud-2.steampowered.com/ugc/615021602296014664/1145A825D8DAC57533D3F8A48C58958CE7027562/

Like that

I will try that now. Also, ty. I have adjusted my post accordingly.

[editline]23rd June 2013[/editline]

I just did that. Everything went smoothly. I will have to play Gmod a bit before I know if this solved the problem. Also, this may be a bit off topic, but Is there anything in my video options that I didn’t do in my screenshot, that would make Garry’s Mod look better? In other words, Is there any way that I can turn up the graphics even more?

[editline]23rd June 2013[/editline]

I just started up Garry’s Mod again and I noticed that it is now forcing me to start Garry’s Mod with different settings. I tried to set everything back to normal, but it keeps starting with these settings…

[thumb]http://i.imgur.com/aLFDo24.jpg

Pretty sure I was having the same issue until I removed the -dxlevel 95 line from my launch options.
Your DirectX level should stay as it is right now when you remove it though.

Worked like a charm. I’ll mark this thread as solved tomorrow if I don’t have this problem again.

In the mean time…

Here is a screenshot of what the “maximum” graphics settings are.

http://puu.sh/3mNqe.png

You can set your HDR, motion blur, and FOV to whatever you want, they don’t relate to “high graphics” settings.

Also, remove the line -dxlevel 95 now that’s it has already forced it.

Thanks man. I’ve allready removed the -dxlevel 95 thing. I’ll see how everything works tomorrow.

Everything works fine. Thank you both for your help.