Ambient occlusion only shows when sprites are being drawn

So I’m not entirely sure if this goes here, but only whenever a sprite is being drawn, such as the light effect from a lamp or light, my nvidia ambient occlusion suddenly starts working.

http://puu.sh/kcSPf.webm

The moment the lamp sprite is no longer visible, ambient occlusion turns off.

Ambient occlusion is not part of the game by default, make sure you are not forcing the settings in your graphics card control panel.

It was set to performance mode somehow, fun. Regardless, is there any way to actually have it work properly? I’ve seen other people use it before.

Ok I just tested it on my regular PC and not my laptop. It works just fine on there, but on my laptop it seems really wonky.

I’m interested in making this work, because it’s pretty and it seems like it may be some hidden setting I have enabled in GMod that would be good to turn off?