AMD Fix possible!

Ok so reading around the forums I was trying different launch parameters because I was tired of the game glitching in the distance…

So I tried -force-d3d11 as a launch parameter and it seem to get rid of all the glitching away

1.)Open steam find rust.
2.)Right Click go to Properties
3.)Click Set Launch Options
4.)Paste “-force-d3d11” without the " "

then launch the game… It seems to work for me and I played a couple hours to test it out… with grass and without grass…

Hope this helps the rest of you with the problem

if anyone can confirm this works i will add it to the troubleshoot thread for easy finding.

also possible fix by garry


garry posted:
Hey guys… can you try running with any of these command lines… to see if they make a difference.

-force-opengl (Windows only)
Make the editor use OpenGL for rendering, even if Direct3D is available. Normally Direct3D is used but OpenGL is used if Direct3D 9.0c is not available.

-force-d3d9 (Windows only)
Make the editor use Direct3D 9 for rendering. This is the default, so normally there’s no reason to pass it.

-force-d3d11 (Windows only)
Make the editor use Direct3D 11 for rendering.

d3d9 works much better for me personally on the hd 7950.

I have the same card… and without -force-d3d11 launch parameter it fawks up…

I have the HD 7970 and I’m having the same problems I’ve given ago -force-d3d11 does not work and I still have problems I’m going to have ago and the other fixes

Card: HD 7750 (grass.on false)

no parameter: many graphic bugs, low frames

open-gl: bug is gone, but font of console (F1) looks quite strange

d3d9: works perfectly, font is ok and the bug is gone

d3d11: bit better than using no parameter

Well since mine works fine with -force-d3d11(dx11) I will keep it that way… but still glad to see others finding fixes either way… Best of luck to you guys

ASUS HD 7870

-force-opengl: Crash on load

-force-d3d11: Ran with less artifacts extremely choppy

-force-d3d9: SMOOTH with grass.on true :slight_smile:

Thanks for the help