"An update is required" So i update, and it STILL says that!?

You’re installing via App ID 4020 correct?

Sounds like an issue with TCAdmin

I would say your GSP needs to update TCAdmin (if TCAdmin has even been updated to work with STEAMCMD yet).