Animations issue

Hi i’m making a NPC with models out of TF2 i decompiled them and came out on these MDL- files

http://cloud.dloaded.com/i/52c181ab2b1cc.png

so i basiclly went over and made my NPC

Here is my init.lua


AddCSLuaFile( "cl_init.lua" )
AddCSLuaFile( "shared.lua" )
include('shared.lua')

ENT.Model = "models/bots/demo/bot_sentry_buster.mdl"
ENT.health = 10
ENT.Damage = 50
ENT.hurt1 = "sound/kamikaze/kamikazed/HurtMinor02.wav"
ENT.hurt2 = "sound/kamikaze/kamikazed/HurtMinor04.wav"
ENT.hurt3 = "sound/kamikaze/kamikazed/HurtMinor06.wav"
ENT.idle1 = "mcsnpchostile/creeper/idle1.wav"
ENT.idle2 = ""
ENT.idle3 = ""
ENT.idle4 = ""
ENT.attack1 = "sound/kamikaze/attack/kami_1.wav"
ENT.attack2 = "sound/kamikaze/attack/kami_4.wav"
ENT.attack3 = "sound/kamikaze/attack/kami_2.wav"
ENT.attackmiss1 = ""
ENT.attackmiss2 = ""
ENT.attackmiss3 = ""
ENT.die1 = "sound/kamikaze/die/die1.wav"
ENT.die2 = "sound/kamikaze/die/die1.wav"
ENT.die3 = "sound/kamikaze/die/die1.wav"
ENT.bCrackSound = true
ENT.dSkin = 1
ENT.dFireSkin = 1
ENT.dBodyGroup0 = 1
ENT.dBodyGroup1 = 1
ENT.dBodyGroup2 = 1
ENT.dFireBgroup = false   
ENT.dHaveBodyGroups = true
ENT.bBGroup1 = true
ENT.bBGroup2 = true
ENT.bBGroup3 = true

function ENT:OnTakeDamage(dmg)
	self:StopSound(self.idle1)
	if math.random(1,3) == 1 then
	  self:EmitSound( self.hurt1,460,math.random(80,120))
	elseif math.random(1,3) == 2 then
	  self:EmitSound( self.hurt2,460,math.random(80,120))
	elseif math.random(1,3) == 3 then
	  self:EmitSound( self.hurt3,460,math.random(80,120))
	end
   self:SetHealth(self:Health() - dmg:GetDamage())  
   if self:Health() <= 0 && !self.dead then 
 self.dead = true;
	self:Killed()
   end
end

function ENT:Killed()
if math.random(1,3) == 1 then
	  self:EmitSound( self.die1,460,math.random(80,120))
	elseif math.random(1,3) == 2 then
	  self:EmitSound( self.die2,460,math.random(80,120))
	elseif math.random(1,3) == 3 then
	  self:EmitSound( self.die3,460,math.random(80,120))
	end
	
  self:Explode()
  

end

function ENT:Explode()
	local explode = ents.Create( "env_explosion" )
		explode:SetPos(self.Entity:GetPos())
		explode:Spawn()
		explode:SetKeyValue( "iMagnitude", "220" )
		explode:Fire( "Explode", 0, 0 )
		explode:EmitSound( "weapon_AWP.Single", 400, 400 )
	self:Remove()
end

Here is my shared and cl_init

In this video my problem gets more explained !

So my question is how do i get it solved that it loads my animations , and that the NPC leaves his T-pose.


$includemodel "humans/bot_demo.mdl"
$includemodel "humans/bot_demo_animations.mdl"
$includemodel "humans/bot_sentry_buster.mdl"


Thx in advance !

might want to post this here
http://facepunch.com/forumdisplay.php?f=65