Annoying Server Issue

Hey guys I am sorry if I posted this in the wrong section because I am getting to know the faceounch forums but I just want to see if you guys can help me out on a server issue that has been bugging the hell out of me.

So basically when I try to join my server it kicks me from the server “my gamemode is sandbox by the way” and it kicks me for too many lua errors, this is what comes up in the console:

[ERROR] gamemodes/sandbox/gamemode/init.lua:121: attempt to call field ‘PlayerInitialSpawn’ (a nil value)

  1. unknown - gamemodes/sandbox/gamemode/init.lua:121

SetPlayerClass - attempt to use unknown player class player_sandbox
[ERROR] gamemodes/sandbox/gamemode/init.lua:41: attempt to call field ‘PlayerSpawn’ (a nil value)

  1. unknown - gamemodes/sandbox/gamemode/init.lua:41

[itzhalo|2|STEAM_0:0:71072986] Lua Error:

[ERROR] gamemodes/sandbox/gamemode/cl_init.lua:86: attempt to call field ‘PostRenderVGUI’ (a nil value)

  1. unknown - gamemodes/sandbox/gamemode/cl_init.lua:86

Dropped itzhalo from server (“Too many Lua Errors! Sorry!”)

I also have set sv_kickerrornum 0 as well but it lets me do nothing and I cant exit without force closing gmod or stopping the server. If needed I will take pictures of what you guys need me to of my files :smiley: thanks

Quick bump :confused:

server.cfg >



sv_kickerrornum 0


I have already tried that as stated here:

If you set it to 0, then it shouldn’t be an issue. Also, I saw your post earlier, you just edited it. You said you had set it to 1.

I know it was a typo but when I do set it to 0 I am able to connect yet I cant use anything, press any buttons, and it wont let me leave without closing the server or using the task manager to end it. Any other ideas?

Did you think to fix the errors?

Well that is where I am having trouble. I have followed the directory to the file and when I edit it with notepad+ O dont know what to change

Well they’re default files so you must have modified them.

Is there any way I can re-obtain the defaults?

Reinstall the server using CMD to a new location and grab the files from there.

Hello, Itzhalo i have the same problem in my server I NEED HELP

[ERROR] gamemodes/sandbox/gamemode/cl_init.lua:86: attempt to call field ‘PostRenderVGUI’ (a nil value)

  1. unknown - gamemodes/sandbox/gamemode/cl_init.lua:86

I have not modified anything. PLS HELP!

And btw that sv_kickerrornum 0 thingy just disable server kicking system for lua errors