Another FastDL problem. Imagine that.

I set up an FTP server for fastDL. It’s anonymous and works fine.
But even with sv_allowdownload set to 0 on my game server, it’s downloading from both the gameserver and the FastDL server. At the same time.

My server.cfg is set up like this (at least the part of concern):
sv_downloadurl http://X.X.X/garrysmod/
sv_allowdownload 0
sv_allowupload 0

Every file in the FTP is compressed in bzip2. While downloading, it shows the bz2 files on the FTP as well and the uncompressed files on the gameserver.

Any ideas? This is more than likely a configuration problem with the game server as the FastDL is actually working. :suicide:
I’m stumped. Been working on this for about 14 hours straight and would like some sleep…

Change

to

sv_allowdownload 1
sv_allowupload 1

it doesn’t matter what sv_allowdownload is set to when sv_downloadurl is set

@wranders PM me the FastDL location and I will take a look

Can someone help me with mine? I just need to see if my directories are correctly laid out. Thanks.
My FastDL site.
Thanks!

Edit:
Just realized how pushy that sounded! I would appriciate any help offered, thanks! :smile:

Yeah, looks good, you would just set sv_downloadurl to “http://samg381.site90.net/Gmod-dl/

Keep in mind you no longer need the cache folder too :wink:

Thanks to Banana Lord, I solved my problem.
If you’re setting one of these up on your own, don’t forget to install an actual web server (Apache, etc.).

My issue was HTTP blocking the download requests because there wasn’t a server there to accept them.