Another hl2.exe has stopped working thread

Before you ask- firstly I did read the Q/A thread, it did not help me. Secondly, I am in fact intelligent, so don’t scream and run thinking that I’m going to have no idea what your talking about. Now then for specs:

  • Processor: Intel Celeron CPU 900 @ 2.20 Ghz, 2.19 Ghz. (I don’t know why it does that- it just says it on my computer properties)
  • RAM: 2 gig
  • Graphics Card: Mobile Intel 4 series express chipset family.
  • Operating System: Vista 32 bit (Service Pack 1, going to update to service pack 2 when I wake up.)

Now again, don’t be fooled by my specs. I can play HL2 on high quite nicely, Episode 1 on high, and Episode 2 on Medium specs. There should (in theory) be no reason for this not to work. However, every time I start up Garry’s Mod- it says, “No fuck you, hl2 encountered a problem and shut down!” (My apologies for swearing, I don’t know the full rules on that nor did I see them, kindly inform me if I did something wrong.)

Now then, I get to the loading screen, so I can see the weird guy with the blue gravity gun staring up at the sky. And it sits there for a few moments much like hl2 does, however right about the time that it should show me a menu, it doesn’t. I just bought this not much more than 3 hours ago, fresh install, I have hl2 installed (and now its randomly installing hl2.1). I also have CS:S and TF2 installed as well. I’v also installed all of my window’s updates except Service pack 2, and I’m pretty sure my drivers are all up to date. Edit: Yup- drivers are up to date.

In any event, thank you all for the help, I really do appreciate it. I’m open for any suggestions (provided they actually help me get Garry’s Mod running of course). Other than that, I’m probably off to bed, and I’ll check this tomorrow.

Alright this is more of an update thing- I updated to Service pack 2 still no dice. Any help at all?

[editline]08:37AM[/editline]

Triple Post of doom. I managed to fix it by going to the games launch options (Right Click Garry’s Mod > Properties > Launch Options) and typing in -dxlevel 8, then launching the game. Once I was in the game I went to the options and lowered everything to low. It seems to be working just fine now. :smiley: