Another retarded error from GMod.

EDIT: Nevermind. I tried reinstalling and it seems to be okay now… Stupid game. Even verifying didn’t work.

Great. I can’t play GMod and I have no clue how to fix it.

Before you accuse me of owning a pirated copy, this is launched from steam on a legitimately purchased copy, and I have HL2, all its episodes AND CS:S installed, as well as other Source games.

When I try to launch GMod, I get introduced to a blue screen with “loading…” in the bottom right. Then it crashes, and I get an error telling me “scripts/surfaceproperties_manifest.txt” is missing…

I’ve heard fixes involving reinstalling addons and such in GMod 10, but I have nothing of the sort… Can I get some help? D:


(User was banned for this post ("wrong section" - postal))

Verify Integrity of game cache.

Steam > Right Click Garry’s Mod > Properties > Local Files

Off topic, I need a better image host.

Already tried that and it didn’t work.

I reinstalled the whole thing (why do I have to REDOWNLOAD it every time? My poor bandwidth…) and it seems to work now. I was hesitant to have to redownload it at first at the expense of my interwebs.

Oh well, nevermind then.

If you’ve verified the cache files, then all you need to do to reinstall GMod is delete the garrysmod folder in your steamapps\yourusername folder, the only thing that’ll have to redownload is your workshop addons.

Wish I knew this sooner.

Thankyou.