Any ETA on Linux Client?

Is there a ETA for linux client?
once it gets into steam early access perhaps?

its so tempting atm… it shows up in the list and seems to have all files
it even starts the game up and by judging the disk activity it seems to load the stuff also but nothing happens … just the facepunch logo stays on the gray screen.

hope to see that solved:)

I would love for a linux client =D

A Linux client is in their “Not so important” section. Instead of waiting, have you tried using wine with steam? I’m sure there will be plenty of problems, especially with rust, but it’s worth a try if you already haven’t. If you have, just dual boot windows in wait of a Linux client :frowning:

i have tried in wine and it works, but i hate to relog to my other steam just because of one game…
also it doesnt work perfectly there.

and i dont have windows and never will

GranPC got it working over the weekend. Try switching to the dev branch.

sadly doesnt work for me.

still getting only into the loading screen
https://dl.dropboxusercontent.com/u/28788188/Screenshot-Untitled%20Window-5.png

will dig into logs as soon as i find time

edit: logs http://pastebin.com/g2kzrSsS

Does Unity not allow compiling to Linux?
I thought it did, @Garry… Whats going on?

ok what i noticed is that librust.so file is missing from
/Steam/SteamApps/common/rust/rust_Data/Mono/x86_64/

even the 32bit executable searches from this location

however there is liblibrust.so file in
/Steam/SteamApps/common/rust/rust_Data/Mono/x86/

but executables dont search for it
so i tried renaming it to librust.so and also copied it to the x86_64 folder but still no go.
doesnt seem to load that somehow.

Dev version should now work?

New update?

Woohoo, Linux client is working for me on the dev version. Sky rendering is broken tho for me, got Intel HD 4000.

AWESOME! LINUX here I come!! Been waiting so long

wooot.

it works now but sadly it has the same nasty mouse bug that few other unity3d games like Verdun and Legends Of Aetherus. While games like Guns Of Icarus and Anomaly 2 its perfectly fine

edit: ok it doesnt seem to be twinview issue also :frowning:

its like something is pulling the mouse up randomly:
https://dl.dropboxusercontent.com/u/28788188/Game-0041.mkv

i dont have any gamecontrollers attached that can do that

just my roccat arvo keyboard and roccat kova+ mouse.

that guy seems to have same issue: http://answers.unity3d.com/questions/435961/im-having-problems-with-running-my-game-on-ubuntul.html

I’ve put that in Trello for Pat to look into, he made the CursorLock

thanks

Keep up the good work!

[editline]6th December 2013[/editline]

hey i replaced my default windowmanager (marco) with xfce one (xfwm4 --replace)
and the issue is gone now

so its probably something that some wm’s and unity3d doesnt get along

[editline]6th December 2013[/editline]
made a bugreport to mate also: https://github.com/mate-desktop/marco/issues/69

any other problems? Installing atm.

mouse scroll doesnt seem to work
cant scroll between items

have to use number keys.

but other than that…it seems to run perfectly

great work!