Anyone else getting this server glitch?

Well, quite frankly i did not know where a server thread would go, because its not LUA scripting, mapping and etc. so i put it here.

Anyway, i have a server provider called [FFS Servers], and i own a Basic garrysmod dedicated server. However some players and myself discovered when you spawn a jeep the entire server instantly crashes… which, is weird.

This is the support message i sent to [FFS Servers].
This problem first happened when i had mods on it, so i removed the mods, and completely reinstalled the server (using the reinstall server action in the FFS
Server control panel) this problem kept happening.

The problem: when someone spawns a vehicle, like a jeep the server crashes! Sometimes people spawn one jeep and its fine, but as soon as another jeep is spawned
the server crashes again. Chairs seem to work ok, Airboats have not been tested (also on a side note, HL2 NPC’s do not make any noise, but there guns do)

THIS IS the default server, there are no mods, SVN’s and no changes of anything from reinstalling, BESIDES updating. The server is fully updated as far as I
know.

Just to clarify this as soon as you spawn the jeep the server crashes, not even a 2 second delay. the jeep is spawned and the server is gone it is instant

The error message in the console goes as follows:

PreMinidumpCallback: updating dump comment
./srcds_run: line 372: 2646 Segmentation fault $HL_CMD
Add “-debug” to the ./srcds_run command line to generate a debug.log to help with solving this problem
Tue Feb 22 16:34:27 EST 2011: Server restart in 10 seconds
Using breakpad minidump system
Using breakpad crash handler

Console initialized.
ConVarRef mat_dxlevel doesn’t point to an existing ConVar
Game.dll loaded for “Garry’s Mod”
Setting breakpad minidump AppID = 4000
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Installing breakpad exception handler for appid(4000)/version(4426)
Mounting hl2… OK
Mounting cstrike… Failed
Mounting dod… Failed
Mounting ep2… Failed
Mounting tf… Failed
Mounting episodic… Failed
Mounting hl2mp… Failed
Mounting portal… OK
Mounting lostcoast… Failed
Mounting hl1… Failed
Mounting hl1mp… Failed
Mounting zeno_clash… OK
Garry’s Mod server.dll Build #112 - Linux
[Feb 8 2011 14:16:28]
maxplayers set to 16
Unknown command “sv_allow_wait_command”
Unknown command “cl_cmdrate”
Unknown command “cl_updaterate”
Unknown command “rate”
maxplayers set to 16
Network: IP 202.157.178.214, mode MP, dedicated Yes, ports 27015 SV / 27006 CL
Lua initialized (Lua 5.1)
Registering gamemode ‘sandbox’ derived from ‘base’
ScriptEnforce is disabled
Compressing lua files into data pack…
Skipped. Datapack exists.
ConVarRef room_type doesn’t point to an existing ConVar
Executing dedicated server config file
[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient.dll. Continuing with current version anyway.
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Failed to load Steam ServiceServiceStart: failed to startUnknown command “sbox_allownpcs”
Unknown command “sbox_playergod”
Unknown command “sbox_maxsents”
Server logging enabled.
Server logging data to file logs/L0222005.log
exec: couldn’t exec banned_ip.cfg
exec: couldn’t exec banned_user.cfg
Client “xJayr ” connected (24.4.121.147:27005).
Connection to Steam servers successful.
VAC secure mode is activated.

This is a very serious problem, and i don’t want to sound negative or anything, but I will not be able or willing to run my server unless this is dissolved

Everything else about your quality and service has been fantastic though and i thank you for reading and helping :stuck_out_tongue:

/Server message

Now they assured me that the server was installed correctly, so i need to ask three questions for server owners and clients (normal players)

  1. Have you noticed that spawning a jeep on other servers causes instant crash?
  2. Have you any idea what files or command lines are missing that could be causing this crash?
  3. Any other solutions

Linux builds crash with vehicles. They shouldn’t really be using linbins as they’re somewhat experimental and pretty buggy (The bug has been reported already - http://gmodbt.bbservers.co.uk/view.php?id=3 with a small not very ideal fix)

Thanks man, at least i know

So which is better. Lin-bins or Wine Win-Bins?

Win Win-Bins. Lin bins are buggy as hell, Wine will cause as many issues as the linbins have in the first place.