Arivia F4 menu- can´t disable printers!

So I purchased the Arivia F4 menu and I like it really much, but I can´t find the option to disable printers in the entities category. I looked to every single file of the arivia but I didnt find it. It said something like the printers will be disabled if I disable them in the DarkRP, but I did and arivia still has its´ own printers in the F4 menu.

Please help.

Contact the script author

Well I tried to contact him but he´s still not replying and I need to fix this ASAP.

Which printers do you want to disable?

The arivia´s custom printers in the F4 menu (Regular printer, ruby printer, Unubtainium printer…).

Where did you put ariviria? (DarkrpModification or Addons)

I put it in addons.

If its possible go to Garrysmod\addons\arvivria\ariviria there should be a entities tab, if not there printers that you put in yourself. You can also remove the whole Entities tab, if you want that please say so

I tried removing the whole Entities tab, but when I do so, the F4 doesn´t work. The files with “entities” in their name are: cl_tab_entities.lua and sh_config_entities.lua. I already removed the Entities folder so the players can´t spawn the printers at least, but they´re still visible in the F4 menu and it takes you money if you click on them.

remove cl_tab_entities, make a backup tho cuz im not 100% sure

This removed the printers, but now whenever I click the “Entities” tab, this error appears in the console:

[ERROR] addons/arivia f4 menu/lua/arivia/cl/cl_init.lua:1342: attempt to index upvalue ‘panel’ (a nil value)

  1. DoClick - addons/arivia f4 menu/lua/arivia/cl/cl_init.lua:1342
  2. unknown - lua/vgui/dlabel.lua:218

[editline]12th September 2016[/editline]

Nobody knows how to fix that???

there should be something in the folders saying cl_tab or something with tab, go over there and remove anything that says entities

if that doesnt work go to addons/arivia f4 menu/lua/arivia/cl/cl_init.lua line 1342 and remove anything that has to do with entities

Notice : Make backups im not sure

Well, there´s a file sh_config_tabs.lua but if I remove the entities from the tabs inside that file, the F4 menu won´t work. In the cl_init.lua at line 1342 there´s this:


if panel:IsValid() then

Files written by the author that are not designated as config files should not be edited in order to fix/remove things without knowledge of lua or unless instructed by the author.

Since this is a script that most of us did not design, we can’t help you. Your best bet is to try to get into contact with the author no matter what, because hes the one that will know how to mend your issue.

Also, the reason why you are getting those errors is because you are deleting the code that builds up the menu, think of it as a bridge ( you take part of a bridge away, you cant cross it anymore )

OK, I’ll wait until the author replies. For now, I’ll be good with this. Thanks for all your help and replies.

Please create a support ticket, we can’t give you assistance out of scriptfodder.

https://scriptfodder.com/scripts/view/1679/ > click on support and we’ll reply promptly

Thanks.

You bought it?

I check my support tickets at LEAST once an hour. So the fact that you’ve contacted me with “No reply” is a down-right lie. Second off, if you want support and access to the ticket system, then purchase the script. If it’s something a buddy gave to you to install on the server, have the purchaser send me a ticket.

Don’t play games to get free support.

-Edit- I checked your SF page, you own nothing of mine. and you registered 14 hours ago. You know using leaked scripts is against SF terms? Well now you do.

Not that it really matters, seeing as he only registered 14 hours ago, but I’ve banned him from ScriptFodder.

Glad to know people use leaks and can’t even do simple scripting.