Attempt to call a nil value?

So that’s not the exact wording, but that’s kind of what it says.

The addon I’m having a problem with is the ST Shuttle Pack… but I’ve had this problem with other addons as well in the past, though I can’t remember what they were.

This is the problem. When I load or start a singleplayer game (never played multiplayer), and then spawn a micro-warpcore, I get this error:
entities/lua/micro_warpcore/init.lua: 39: ‘LS_RegisterEnt’ attempt to call global (a nil value)

and this error scrolls repeatedly:
entities/lua/micro_warpcore/init.lua: 141: ‘RD_GetResourceAmount’ attempt to call global (a nil value)

I also get similar errors for the other items in the Shuttle Pack, pointing to similar areas in their init.lua files.

If I remove these items, the errors stop scrolling. However, when the items are out, I cannot link them to any other RD/LS things.

As far as I can figure, this error doesn’t really stop me from doing anything else. I can remove the addon and play normally. Actually, I can play normally with it installed as long as I don’t use those items.

I’m not sure how to make a log of my console, otherwise I’d just post that. Instead, I just repeatedly opened and closed Gmod and wrote it down a bit at a time into notepad. If that, or any other info, is needed, I’ll be happy to give it.

I appreciate any help given.

Edit: These are the steps I’ve performed to try and narrow down the problem. First, I renamed my Gmod folder, started the game. Then, one by one I started adding mods. I started with Wire, Wire Model Pack 1 and Wire Extras. Redownloaded them from the svn on the Gmod wiki. After that worked, I then installed LS3 and RD3. I got those just two days prior from Snakesvx’s wiki page. I followed the page’s instruction closely. After testing those, I then installed the ST Shuttle Pack addon, from the svn on the Gmod wiki. I start the game, start a new singleplayer, spawn the MWC and get the same error from before.

So, I guess I can fix the error by removing that addon, but that’s not really a fix, it’s more of a “give-up”.

This is a bit off subject but, dont you think it would be smarter to just go into gmod and write it down then exit gmod and post it?

Yeah, but I couldn’t find a pen, and Gmod crashes if I Alt+Tab it.

Are you using it with an incompatible version of Spacebuild?

Edit: Problem solved. Not compatible.

what spacebuild version did you use?


(User was banned for this post ("Please read post dates! This thread is six years old." - NiandraLades))