Attempting to host a server -- unable to connect myself.

alright, so today that my bad old linksys router (wrt54g) is able to finish downloading all the server files without shitting itself and messing up the process (unlike last time i tried!) i decided “hey why not try hosting a gmod server again.”
so i went down to google.com followed This Guide, downloaded all the files, forwarded some ports, made some firewall exceptions, but for some reason i’m unable to connect to my own server when it’s hosted. i tried connecting via “connect localhost” and using my external ip, with no luck. Basically whenever i try connecting i don’t get an error or anything it’s just the typical connection failed after 4 retries… i tried searching very loosely to see if there was a fix for the issue, but no luck. so there are a few ideas i have

-stated in the guide i linked above, are forwarding ports UDP 27015 and 26901 necessary? i can’t forward UDP 27015 because it says something about overlapping ports, and i haven’t tried 26901 yet because i’m not interested in getting my server listed/publicized

-i’ve tried checking with this: http://cpfx.ca/srcds/portcheck.php and i got fails, but my excuse for not trying to fix this is because i’ve had experiences with port checkers in the past where they initially said my ports were not opened, but truth just so happened to be everyone could connect fine to me and my router tends to take it’s time responding to things often, which makes me curious if there’s any more specific way to check if my ports are really open

-see description of 3rd screencap

some screencaps…

http://i.imgur.com/N7cyb.png - router access panel or w/e the fuck it is
http://i.imgur.com/Kkool.png - srcds
http://i.imgur.com/X4yFQ.png - firewall settings (maybe there’s something with the first 4 inbound rules i didn’t set? no clue)

is there any other details i need to give or did something completely obvious go over my head. not very experienced in hosting servers

You are forwarding to the wrong IP.

In your SRCDS console you can notice that your internal ip is 192.168.1.104.
While in your router panel you are forwarding to 192.168.1.102.

and it works.

…even if that was horribly obvious, thank you for bringing it up