Auto Vote Map Code For Prop Hunt Server?

Does anyone have any idea how to configure their dedicated prop_hunt Server to use the fretta map vote automatically when no one selects a map so that it doesn’t crash?


(User was banned for this post ("wrong section" - postal))

Can you link the version of prop hunt you are using?

I use Kow@lski’s Original prop hunt located here: http://xspacesoft.github.io/PropHunt/
I have the same issue with the game mode changer freezing the server if the timeout is reached. Is there any way to make it immediately go to mapvote, or force it to pick the game mode?

I don’t understand why it’s crashing. It already has something that chooses a random map if there’s no winner:


	if ( !winner ) then return GetRandomGamemodeMap( GAMEMODE.WinningGamemode ) end

Here is the gamemode: http://steamcommunity.com/sharedfiles/filedetails/?id=207938283&searchtext=prop_hunt And I have ulx to support it. And, I also have already made the correction to the map.config adding ph_. I don’t have a problem getting the vote system to come up, it just freezes up if there is no one there to choose, and I want to leave my server up without the crash.

I also don’t know where to put this included file… http://tinypic.com/r/6oolcy/8 which might be the problem.

I have the gamemode itself added to my fast dl and autorun workshop.lua, so it should work.

[editline]9th May 2014[/editline]

This is the error message right when I start the server up, before the actual vote:

[Prop Hunt (ULX Version)] lua/mapvote/rtv.lua:17: attempt to index field 'Config
’ (a nil value)

  1. unknown - lua/mapvote/rtv.lua:17
  2. include - [C]:-1
    3. unknown - lua/autorun/mapvote.lua:50

Here is the file for the first error line. Something to do with Mapvote.Config being an error…

Line 17: RTV.PlayerCount = MapVote.Config.RTVPlayerCount or 3

[editline]9th May 2014[/editline]

This is the end report from console when the mapvoting starts:

[ERROR] lua/mapvote/sv_mapvote.lua:59: attempt to index field ‘Config’ (a nil va
lue)

  1. Start - lua/mapvote/sv_mapvote.lua:59
  2. unknown - gamemodes/fretta/gamemode/init.lua:496

Timer Failed! [Simple][@gamemodes/fretta/gamemode/init.lua (line 496)]

That’s the wrong folder; there shouldn’t be a gamemodes/lua folder. Move those to garrysmod/addons.