average boot time for hammer?

I’m just curious.
Mine usually only takes around 1-2 seconds max.
But when mapping for GMod,
it’s a full 10 seconds from clicking that button to being able to use hammer.
Probably because I mount EVERYTHING that’s compatible for GMod mapping, never know when you’ll need one random model or texture from another game.

It depends, I have a mod that has a ton of stuff in it! So it takes longer to implement it all in. The mod with all the stuff takes about 10-20 seconds at times to load.

please post in question thread next time.

i look around for the best area to put something in, and i always end up messing that up anyways. -_-
wow, i get sick of waiting at 10 seconds (with hammer, because it’s usually 1 second) but 20 seconds? i would walk away and do something else quickly.
i know you need patience to map, and i can map for hours on end, but loading while doing nothing, and nothing to look at, that annoys me

20 seconds isn’t that long. Once upon a time L4D2 tools took about 5 minutes to load, then there was that awful period where it got updated and something broke and it took about 20 minutes to load. Then they fixed it and it’s now anywhere from 5 to 60 seconds for me. Usually the latter when I’m starting it for the first time in a day.

If you need something to do just keep Facepunch open or listen to music, it kills time when you do something like compile, start the SDK, load your model browser, etc.

Bro, its 10 seconds out of your life. If you really have a problem with that, go see a doctor.

i know it’s an incredibly short time, but when something normally boots in a second, 10 seconds feels like an awfully long time.
Also, i was asking for average boot times, i wanted to see what other people thought on boot times, not what people think on my thoughts of boot time.

yeah, i tried l4d2 mapping once, didn’t like the feel, it seemed like it was thrown together in a hurry, and yeah, it takes a bit longer to boot.
compiling i tend to just walk away (with a sign on the computer saying not to touch it under penalty of death) model browser doesn’t take a long time to boot, just to load the models (and when i have all my source engine games mounted, that equates to a HUGE number) so i usually browse it while it’s loading the props.

What’s different about it from Source SDK? Aside from new props, textures, and entities.

Yeah, L4D1 and 2 Hammer always took some time to load. Good thing It’s not as long now.

mine boots in like 5 seconds

I think it also depends on your system. In comparison:

Keep in mind that I have my steam folder on a seperate partition, so after each windows reinstall I only have to reinstall the steam client on that partition, and evertything is up and running. So my sdk files never change.

At first I had a Intel core 2 quad Q6600 with 4 gigs of DDR2 RAM. It took about 5 to 10 seconds to load after a fresh windows install. Now keep in mind what I said earlier about my SDK files never changing. I upgraded my system a few months ago to an Intel I7 with 8 gigs of DDR3 RAM. The harddrive remained unchanged. Now hammer boots in a fraction of a second.

I guess what im trying to say is that a large portion of loading time is influenced by your system specs.
I don’t think the amount of content (models/textures) have a big part in it, because the models are only being loaded when you open the model browser. I am not sure about the textures, but due to the fact that you can add custom textures while hammer is running suggest they arren’t preloaded either.

Only thing i could think of is the amount of custom entities added.

Hammer boots up pretty quickly for me. But often exiting is another story:

“Please close Source SDK before exiting Steam”
“Please close Source SDK before exiting Steam”
“Please close Source SDK before exiting Steam”
CTRL ALT DEL

(and yes I did close hammer properly)

This happens all the time with me. Especially with TF2.

If I was your source sdk, I wouldnt want to close either seeing your island map.

oh GOD how i know that, especially with TF2 or if i try to screw with the lighting past the engine’s limits and vrad silently crashes…

I’m not sure, it just feels… wrong…
usable, but wrong…

i like it. i have over 20 gb of content in my ep2 install (or I did), and it feels different. it’s a lot smoother than my ep2 hammer, and the entities are great (like precipitation blocker… we need some of those in the ep2 engine), and the compiler doesn’t freeze, because it treats it as a command prompt type thing. but hey, that’s just my opinion. we are all entitled to one.

Depends for me.
The L4D/L4D2 Authoring tools take about 4 seconds

Most source games that come with the editor by default load up instantly for me (Unless I have a lot of processes at once, then it takes a couple seconds)
It also may take more time if I have a lot of extra content (materials,models,sounds,scripts etc.)