Bad fps with GTX 770

No matter what graphics I choose i get like 40-50 fps (grass is off. it looks the same no matter what graphics I choose). My specs are: gtx 770, i7 4770k, 16 gb 1600 mhz ram. Any idea why, and fixes?

System seems to be okay i dont know the problem either
Maybe its ur something with software or drivers but i think 40-50 fps is enough to play the game?

I have a GTX 770 SC, and I’m getting around 90-130 all the time. So it may be something for you, your specs are a lot better than mine, so I don’t quite know.

You should update all your drivers if you havent yet
Or, if you have too much time on your hand, do a new clean windows installation and install rust again
But i would do this as last possibility and if you really want to play rust with that much frames

I used to be able to run rust 40+ fps but ever since updating I can get 30 but frames jitter a lot. No idea whats up with it.
I have a Radeon 6670 currently.
Just ordered a Radeon R9 270X for Christmas. Hopefully that can handle it.

weird i have gtx 760 oc with i5 4770k at 5ghz runs at max 100fps lowest 85fps max settings 1080p

oh look another smexy :wink:

another smexy?
funwithsmexy is my account i play on if thats the other smexy you have seen

Can i ask u what 770GTX u have?
I have the same problem with my but this one is totaly broken, every Game is laggy etc.
It’s a GTX 770 Palit (non OC)

Yeah, my frames kinda stops for a split second and starts again sometimes, i don’t know what that is, but probably optimizing issue. R9 270x is a great card, congrats :slight_smile:

[editline]21st December 2013[/editline]

Hi. The most games i play, run smooth (except for bf4 tho). I have, gainward gtx 770 phantom (non OC)

[editline]21st December 2013[/editline]

hmm, what graphics do you use then, i run “beautiful” but it doesn’t seem to make any difference on what I choose either for the looks nor the frames.

I run it with i5 3570K @ 4.2Ghz + Asus GTX 770 and no problem for me around 90-180 Fps all time

Switch to high performance instead of interated.

Outdated drivers, perhaps?

4770k is i7 fyi

as for OP, try disabling alot of the antialiasing settings/shadows/etc using the nvidia control. You can force the game to disable those features since it doesn’t have a gui to turn em off.

nope, newest drivers :confused:

[editline]21st December 2013[/editline]

where do i do that?