bad prop lighting

these tracks are set as a prop_dynamic_override as its the only one they show up as. for some reason they have TERRIBLE shading and im not sure how to get around it.

That’s source for you. Dynamic props, as well as static props with normalmaps, will always be lit according to the model’s origin. The best solution is to use a non-bumpmapped static prop, or if that’s not an option, set a lighting origin manually so the track is at least lit evenly, or tune your light_environment to avoid casting lightmap shadows on the tracks altogether.

damn thats irritating. thanks for the help.

Sees the post, eyes widen Thank you dear sir.