BF3 Vaulting

So I was working on a fix for the BF3 Vaulting mechanism, but I can’t seem to figure out how to fix this.


[ERROR] addons/floras bf3 vault/lua/autorun/client/css_legs.lua:28: attempt to call method 'VaultViewSet' (a nil value)
  1. v - addons/floras bf3 vault/lua/autorun/client/css_legs.lua:28
   2. unknown - lua/includes/modules/hook.lua:82


[ERROR] addons/floras bf3 vault/lua/autorun/client/css_legs.lua:207: attempt to index global '_R' (a nil value)
  1. unknown - addons/floras bf3 vault/lua/autorun/client/css_legs.lua:207



Client:

There is no such table “_R”, you want “debug.getregistry()”. It literally says it right there in your 2nd error “attempt to index global ‘_R’ (a nil value)”.



local meta = FindMetaTable( "Player" )


Is preferred, though.

Once you finish this, would you mind posting it somewhere? This would be really interesting.

Sure enough, As soon as I finish fixing this.

[editline]5th October 2013[/editline]

So what do I do?

You stop being lazy and try to fix it yourself using the knowledge that I just gave you. I’m not a babysitter.

How does one create timers for emitting sounds?

this other error still persists


[ERROR] addons/floras bf3 vault/lua/autorun/client/css_legs.lua:29: attempt to call method 'VaultViewSet' (a nil value)
  1. v - addons/floras bf3 vault/lua/autorun/client/css_legs.lua:29
   2. unknown - lua/includes/modules/hook.lua:82




[editline]5th October 2013[/editline]

Ok seriously guys. Stop Listing me as ‘Dumb’ and help out.
I used the Code provide by EvacX. And it still doesn’t work.

Anyone?

According to your error, VaultViewSet does not exist. Think.

Change _R.Player:VaultViewSet just to VaultViewSet?

If you had correctly done what EvacX said then you wouldn’t be having that error.

Heh. I repaired this addon for a friend, maybe i still have it.

Ends up with this.


[ERROR] addons/floras bf3 vault/lua/autorun/client/css_legs.lua:8: attempt to index global 'PL' (a nil value)
  1. v - addons/floras bf3 vault/lua/autorun/client/css_legs.lua:8
   2. unknown - lua/includes/modules/hook.lua:82



Did I mention I don’t know Lua that well? >.>
should I change ‘PL’ to ‘Player’?
I’m sure that’s not what I should do.

[editline]6th October 2013[/editline]

Nvm, Fixed the errors
But it still doesn’t do what it’s supposed to do. Vaulting. I can’t see the CSS legs or anything.

Can anyone help with the legs?
The addon errors are fixed. It isn’t doing what it is supposed to do. Frankly, it isn’t doing anything.
Oh, and I apologize for my stupidity earlier.

we’re not holding your hand

Dude, I have no clue why this isn’t working. any suggestions?