Binds are messed up.

It happened about a couple days ago. I realized my backspace and tilde key (~) were not working. Naturally i thought it was the server so i try it in single player. Doesn’t work either. Then I delete my config file were the binds are kept so it generates a new one. It still doesn’t work. This cuts off my access to console which is very bad for me. Any one got a fix for this?

bind ~ console and with the backspace problem, dah fuck?

Can’t bind if I can’t get into console unless there is another way to bind.

just edit the controls in options.

There is no backspace or console in the edit key options.

Open steam, right click Gmod, properties, set launch options, type “-console”, click OK, launch gmod.

What about the backspace.

When you launch Gmod, the console will be there. Then you can use the console’s “bind” command to bind it to whatever you like.

Nope didn’t work none of them worked. You can’t press the ~ key in console because it will close it and you can’t bind backspace because it’ll just backspace. I also tried bind backspace backspace and it didn’t work.

change your keyboard.


bind backspace toggleconsole

The keys work fine outside of Gmod.

[editline]01:18AM[/editline]

Already tried that Divrian, i tried binding it to p but to no avail.

re-install gmod.

^ I guess i’ll do that then.

Also what keyboard layout are you using? Could be something to do with that.