Black lines in L4D skybox

I have these black lines appearing around the edges of my custom skybox, and nothing I do seems to fix it. It works fine in OB games.

Why you put this in Garrysmod Forums?

It doesn’t matter what game you are making maps for, we will always answer if we can. We are a bit of a rebel forum in that respect.

lolololol

Try turning down filmgrain and turning up AA?

Looks like you didn’t even make a skybox? It looks like you made some blocks and textured it with a texture of a skybox.

4xAA I don’t believe it has anything to do with that, since all other skyboxes work fine without AA.

I know how to make skyboxes, this one consists of custom vmt and vmf files created by me, which all uses the same settings as the L4D skybox files. The brushes have the correct skybox texture applied.

Post your .vmt
I have one custom skybox that works, I can compare them and see if there’s anything that might be causing it.

“UnlitGeneric”
{
“$basetexture” “skybox/dusk_up”
“$nofog” 1
“$ignorez” 1
}

I just said it looks like it.

I just answered.

Did you set the Clamp S and Clamp T options correctly in the VTF?

Yeah I did. The Clamp flags usually fixes this kind of problem, but not this this time.

I know this sounds stupid, but double check your textures and make sure there are no grid lines? :v:

The only difference in mine is that there’s no quotation marks on $ignorez 1.

So your skybox brushes all have the toolsskybox texture?