Black squares in the place of blood

Usually I can correct any problem with a clean reinstall of Garrysmod, which I usually recommend to people when they are having problems. Well, I decided GMod was loading to slow and I wanted a clean start, so I deleted my garrysmod folder and let the cache rebuild it. Installed the most basic addons that most servers use, then joined a server to play.

Whats happening is that every time a human or myself is shot, instead of blood, it produces a big black square. Multiple shots make multiple squares.

What I have tried so far:

-Deleting the Garrysmod folder again.
-Verifying the Cache
-Defragmenting the Cache
-Checked to see if the blood decals work in other Source based games(which they do)
-Deleted the Garrysmod folder again…
-Updating my drivers
-Restarting the computer(doh)
-Checking the console for errors(nothing short of the usual)
-Searching FacePunch

Computer Specs:
Q6600
2 8800Ultra in SLI
3GB RAM
32bit Vista(don’t even go there)

If anyone could shed some light on this problem, it would be greatly appreciated.

Here is a picture.
http://img57.imageshack.us/img57/3486/gmflatgrass0000hp7.th.jpg

uninstall and reinstall Garry’s Mod. Go into your games folder, right click Garry’s Mod, and select “delete local content”. Then re-install.

This is your dx10 card messing up gmod’s directx. Try manualy forcing gmod to use dx9:
Steam - My games - rightclick gmod - properties - set launch options - type this:

-dxlevel 90

just download a new bloodpack, hopefully that will fix it

If none of the above work the delete source materials.gcf and other gcfs that you think may need to contain the blood material, in steam/steamapps. Have steam redownload the content, and start gmod.

Before you try this though, if you have hl2 ep2. Try launching it and see if the blood is normal is so then retry gmod. If this doesn’t work then do what is said above. The gmod2008 update has hl2 ep2 blood.

I got the same problem. when i first got Garry’s Mod it worked perfectly but now all the blood in Garry’s Mod and team Fortress 2 have turned into black squares. Normally, it would work fine but on that day i got a notice that said i needed to update my drivers, so i updated them but it didn’t work. I have tried everything posted above and nothing worked.

I’m also getting this problem now. I’ve deleted all the source engine cache files, and the source 2008 files. Still after downloading them all over again, the big black squares still pop up. Anybody got a solution?

no… CRAP

I have this problem too. I hope that someone knows solution. :frowning:

Edit:

Can someone fix this problem?

Could it to be with


InitFastCopy: only 49% fast props. Bug?

?

because it’s as if the blood does not precache

Edit:
By any chance are any of you either

a) running windows xp
b) run/ran service pack 3 for windows xp
c) did not have .net framework 2.0 installed when trying to install the catalyst control panel/drivers

These are things that I guess could contribute to this odd problem

I had the same blood problem, then i ran episode 2 and it all got fixed.

Okay, if any of you still need a fix to it, I finally got it working for myself last night.

This is only if you’re using an ATI card.
After trying all of the above things and having them not work for me, I downloaded the 8.7 beta drivers. The black squares are now gone and performance on the whole is better

It says the same thing too for me in console

Okay sorry for the multiple posts but I think I’ve finally figured out why the black squares are appearing. Just a couple of minutes ago, the black squares reappeared after I thought I had fixed them with the driver update.

After looking at the gmod changelog, there was a problem with TF2 blood overriding HL2 blood. A couple of threads confirm that the bug still exists so I’m guessing this is the problem because

a) I’m using the TF2 low violence content - hence the blood is missing from this GCF and gmod is trying to get the blood model from here.

b) I don’t know how to change from low violence content to the regular content.

Edit:

Okay got a permanent solution.
If you delete the “team fortress 2 low violence.gcf” steam rebuilds it on gmod launch.
to get around it, just create an empty text file, rename it “team fortress 2 low violence.gcf” and set read only on it :v

works like a charm. oh btw you’ll still get tf2 blood, but it’s still better than black squares.

Do you’ve a link for those beta drivers?

Yes I do.

VISTA
8.7 Beta Catalyst Drivers VISTA 32/64bit

XP
8.7 Beta Catalyst Drivers XP 32/64bit

since you’re just asking for the drivers I’m guessing you don’t have the black square problem. But if you do just look in my post edit from before.

Edit: some people in the ati forums are having trouble with the drivers.
I suggest a full uninstall of all drivers before testing these.

Whats a text file? because i deleted “team fortress 2 low violence.gcf” and i made a text document and named it “team fortress 2 low violence.gcf” and set it to read only but steam still made a new copy of the original team fortress 2 low violence.gcf.

A .txt file, like right click in the folder > new > text document

GMOD should not re-download the content if it is read only. If you are using vista, you’re not running steam or gmod by right-clicking and selecting run as administrator?

also, in your console you should have a mount error or two under the section about TF2

It doesn’t work. i know i may sound like a noob but it doesn’t work. Steam keeps reinstalling the file. Plus i don’t have a text.file. I only get text document.
right-click>new>text document that’s all i have.

After every fresh install of Garry’s Mod, you need to run each of your Steam games once. I don’t know why, but if I don’t, I can’t access props from that game.

If that doesn’t work, check your video settings. Click advanced and mess with the settings in there.

If that doesn’t work, type “-dxlevel 90” (without quotes) into launch options.

If that doesn’t work, type “-dxlevel 89” (without quotes and make sure its 89, not 90) into launch options.

If that doesn’t work, reinstall ALL Steam-related products (all your games, and Steam itself. Make sure you backup saves/screenshots/adv dup files, and make sure you restart)

If that doesn’t work, run Windows Update. Just to be sure.

Other than that, keep in mind that Garry’s Mod is a MOD and will usually come with problems like that, although there’s probably a fix for it somewhere out there. Look on www.garrysmod.org for a fix.