Black Texture Glitch?

First off, I’m sorry if this is the wrong forum but I was pointed to this one by someone else. I’m also sorry if I’m not really doing this right…

For a while now I’ve been getting weird black textures on my props and sometimes ragdolls in Garry’s Mod and other Source games. At first I thought it was Max’s Lightwarp but then I realized it didn’t start RIGHT after I installed them, and it’s been happening in all my other Source games when I only installed them to Garry’s Mod. The black texture isn’t even in the same place the whole time which really confuses me. As does the fact that identical parts seem to not be equally effected. Sometimes entire objects (like ones from The Ship) are glitched. Here’s a picture of what happens.

These are my system specs. They’re not reccomended but they’re still a bit above required, and I know people with worse computers than mine that don’t have this problem.

      Processor: Pentium(R) Dual-Core CPU       T4400  @ 2.20GHz (2 CPUs), ~2.2GHz
         Memory: 4096MB RAM

Available OS Memory: 3004MB RAM
Page File: 2398MB used, 3609MB available
Windows Dir: C:\windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7600.16385 32bit Unicode

My video card is Mobile intel 4 series express

I did try running -dxlevel 81 in gmod. It worked for most things but it got rid of my lightwarps and nothing looked very good for what I use gmod for. But even then the black textures on Heavy’s hands did not go away when I entered that into my launch options. Plus as I stated before this is a new problem that doesn’t SEEM to stem from anything I did. I also verified and still nothing.

If I do need more memory or a better graphics card that’s one thing and fine, but since that doesn’t seem to be the problem I want to try to figure out if there’s any other way to fix this before I drop money in a solution that may not work.

Any help would be greatly appreciated.

most likely because of your intel card, try and using different launch options, there was one in particular but I am at school and can’t look at it

I actually used to have this problem too, but when I had it, it was because it was running on an external drive. You could try upgrading your card, otherwise, I wouldn’t know.

Is it other than the dxlevel ones? Because I haven’t seen any other than that. I’d be very willing to try though if you ever locate it whenever you have the chance. I’m kinda bummed that it could be a graphics card problem since it was working before. But I guess that’s life. It’s not like a better graphics card is gonna hurt though.

I thought I read somewhere it could be a phong issue, but I know nothing about that sort of thing really. I see so many conflicting stories so it’s confusing. I want to try whatever that launch option may be and deleting local content and seeing if that fixes things because I sink money into it though.

Is it alright for me to ask what sort of graphics card you may suggest? I don’t know much about graphics cards. I have a Lenovo laptop.

Thank you for your help.

Try this.
-dxlevel 81 +mat_forcehardwaresync 0

Thanks for the help, but it didn’t yield any better results than just -dxlevel 81. I guess it’s just time for a new graphics card.

Thank you again for all your help! I’m off to research what graphics cards.

Ok sorry I couldn’t help any better