Blender crash when exporting my textured model into a smd file

So I just finished my model but when I wanted to export it, Blender crashed.
Please, help.

PD: I’ve tried many times, but I didn’t get any results

Save it as another format, open it in another program and export it from there.

Like what program do you mean?

3DS MAX, Maya (Some more cant remember I think)

Open the console (Window > Toggle System Console) and tell us what it says.

Nevermind, I reinstalled SMD Tools and now it doesn’t crash but I get an error:

Traceback (most recent call last)
File ‘‘C/Users/’‘Username’’/AppData/Roaming/Blender Foundation/Blender/2.66/scripts/addons/io_scene_valvesource/export_smd.py

ETC…

What do you think guys?

Replacing all the useful information with “ETC” probably isn’t going to help him solve your problem.

Alright I’ll copy all of it, all the files are so similar but well:

Traceback (most recent call last)
File ‘‘C/Users/’‘Username’’/AppData/Roaming/Blender Foundation/Blender/2.66/scripts/addons/io_scene_valvesource/export_smd.py’’, line 217, in execute self.exportObject(context,object,groupindex=i)
File ‘‘C:/Users/’‘Username/AppData/Roaming/Blender Foundation/Blender/2.66/scripts/addons/io_scene_valvesource/export_smd.py’’, line 302m in exportObject ifself.writeSMD(object,groupIndex,path+getFileExt()):
File ‘‘C:/Users/’‘Username’’/AppData/Roaming/Blender Foundation/Blender/2.66/scripts/addons/io_scene_valvesource/export_smd.py’’, line 964, in writeSMD self.bakeObj(smd.m)
File ‘‘C:/Users/’‘Username’’/AppData/Roaming/Blender Foundation/Blender/2.66/scripts/addons/io_scene_valvesource/export_smd.py’’ line 778, in bakeObj bpy.context.window_manager.progress_begin(0,len(bakes_in))

Atribute Error: ‘WindowManager’ object has no attribute ‘progress_begin’
location:<inknown location>:-1

That’s the whole error I get when exporting.

PD: File ‘‘C:/Users/’‘Username’’/AppData/Roaming/Blender Foundation/Blender/2.66/scripts/addons/io_scene_valvesource/export_smd.py’’ Brings you to the folder where the SMD tools have been installed but I cannot understand it.

Thanks.

Not sure what the problem is but I had a similar one.

Download Blender.zip (NOT the exe) so you have an installation that isn’t reliant on any User folders, This way you have a 100% fresh install that wont be affected by any changes you make to your normal Blender, 100% factory settings, I also recommend downloading 2.65 instead as that is what the addon was updated to.

then throw the SMD addon in here:
Yourlocation\blender-2.67b-windows64\2.67\scripts\addons (I guess 2.67 works as well, may as well give both a shot)
and enable it in the Blender settings.

This works for me, though the error could be different.

I cannot install the SMD tools in Blender 2.65 or 2.67, Could it be due to the Source Tools? They are in the newest version: SMD Tools 1.8.0

I just tried both 1.8.0 and 1.7.0 (What I was using) and they both work

But here’s a link to 1.7.0 regardless:
io_smd_tools-1.7.0.zip (47 KB)

But wow they butchered 1.8.0, hardly any options/settings and no option to export from File>Export

Wow, I tried 1.7.0 and it works but not with my model, I mean, I can export a cube for example is my model too big or something?

[editline]8th July 2013[/editline]

YAY! It was too big so I deleted some loops and stuff and exported! Thank you all guys!!!