$Blendmodulatetexture and $envmapmask aren't close friends - Textures for my map.

I have a question, I made two textures for my map which look like this :

Pavement blends with hay.
Hay blends with grass.

Now praise my ultimate stupidity and brace yourself :



"WorldVertexTransition"
{
	"$basetexture" "Pavement_Grass/Pavement"
	"$bumpmap" "Pavement_Grass/Pavement_nrm"
	"$envmapmask" "Pavement_Grass/Pavement_env"
	"$envmap" "env_cubemap"
	"$basetexture2" "Pavement_Grass/Grass_1"
	"$bumpmap2" "Pavement_Grass/Grass_1_nrm"
	"$envmapmask2" "Pavement_Grass/Grass_1_env"
	"$blendmodulatetexture" "Pavement_Grass/Pavement_blm"
	"$nodecal" 1
	"$surfaceprop" "Rock"
	"$surfaceprop2" "Grass"
}


What I wanted to do was having a blend texture with bumpmaps (nrm), envmapmasks (env) and blendmodulate texture (blm).
The point is that my envmapmasks are not “displayed” in game after building cubemaps which makes me cut my wrists as I am too big of sissy to cut my throat.
Normally I’d use $normalmapalphaenvmapmask 1 but $blendmodulatetexture does not go well with it, aka it’s not working.
Right now I use envmapmasks separately, and it still is not working.
Also I tried putting envmapmasks into the diffuse texture’s alpha channel but this way only basetexture 1’s would be rendered while I want two to be rendered because I am a retard.

Issue #1 - I don’t know if $envmapmask2 is a valid line, I tried running a map and building cubemaps without it but the results were the same.
Issue #2 - Usually I can see if the texture has envmapmasks in Hammer by this shiny layer on texture when using camera with “3D textured” setting but now I don’t, so obviously something is wrong.

Also, I use Source 2007 thing to build cubemaps, it worked so far. I wanted to use $basealphaenvmapmask but it would render envmapmask of basetexture 1 only.

If you have some tips, solutions, ANYTHING… I beg of you, help or I’ll die of being a bad mapper.
Also I didn’t put it in megathread because I was stupid and didn’t think of that. I still think that this topic deserves its own… topic as a lot of into has been put into it.

Make sure the map doesn’t have default cubemaps. :stuck_out_tongue:

If it does, check this out. http://forum.facepunch.com/showthread.php?t=1293081

It does not. Even if it has, Source 2007 always overwrites them and it is working one way or another. (Try for yourself) I am 100% sure that the problem is with the texture vmf.

I’m not quite sure what you are trying to do but I am pretty sure it can’t be done.

Now guys I will blow up your mind.

“LightmappedGeneric”
{
“$basetexture” “Pavement_Grass/Pavement”
“$bumpmap” “Pavement_Grass/Pavement_nrm”
“$basetexture2” “Pavement_Grass/Grass_1”
“$bumpmap2” “Pavement_Grass/Grass_1_nrm”
“$blendmodulatetexture” “Pavement_Grass/Pavement_blm”
“$ssbump” 1
“$normalmapalphaenvmapmask” 1
“$envmaptint” “[2 2 2]”
“$basetexturenoenvmap” 0
“$basetexture2noenvmap” 0
“$envmap” env_cubemap
“$nodecal” 1
“$surfaceprop” “Rock”
“$surfaceprop2” “Grass”
}

Fun facts :

Despite breaking developement site, the texture works, it is blend texture which has blendmodulatetexture, 2 specular masks put into bumpmaps’ alpha channel, 2 bumpmaps and it all it LightmappedGeneric.

I know that textures are alpha reversed but the results are simply stunning in game (after re-reversing textures).
My point is, whom can I trust if the very DEV site lied to me ?