Bone Weights Problem (Using 3DS Max 2012)

Issue has been resolved. Help is no longer needed.
[del]So I having this problem for two weeks now and I can’t seem to figure out a complete solution to this issue.
Here’s are the pictures depicting this problem. All of these are within a span of two weeks.

http://images.akamai.steamusercontent.com/ugc/449581287549046055/133607699058F5F79067215EC48136ACF60422EC/?interpolation=lanczos-none&output-format=jpeg&output-quality=95&fit=inside|1024:640&composite-to=,|1024:640&background-color=black[/t]
[t]http://i.imgur.com/Hi2IEYL.png[/t]
[t]http://i.imgur.com/WFYiRUC.png[/t]
Before Saving and Exporting:
[t]http://i.imgur.com/MgfsxmM.png[/t]
After Saving and Exporting:
[t]http://i.imgur.com/wX5CD01.png[/t]
[t]http://i.imgur.com/tDzSsp8.png

I don’t even know why this problem is happening and I have tried everything I could to in an attempt to fix it myself, but I can’t figure out a solution to this problem.
I mean did I missed something or did something wrong?
(Note: Pictures are recommended, so not only I can pinpoint where I did wrong easily, but also it shows proof that the said method potentially works. Also details, I can’t not say this enough. Put a lot of details in the explanations so I can understand what you are trying because I don’t know everything about 3DS Max right off the bat.)[/del]

Anyone want to lend a hand on this?

As your image shows Wall Worm is installed, I’ll offer some tidbits. This isn’t necessarily the case, but it could very well be. The SMD Exporter inside Wall Worm supports proper skin weights only in 3ds Max 2014 - 2016. In older versions of Max, the functions for skins were different, and I have no intention on updating WW to accommodate this.

As such, you have two options:

  1. Set Wall Worm to use the Wunderboy SMD Exporter in the global settings when using 3ds Max 2012

or

  1. Upgrade 3ds Max (Max 2015+ is preferred with WW)

#1 is fastest but #2 is probably the best long-term solution as there are many features in WW that only work well with later versions of Max.

If you don’t have the Wunderboy SMD Exporter and you use #1, you need to download it from his site before setting WW to use it.

Hopefully this magically solves your problem.

If not, here are some other tips:

  1. With skinned models, almost always turn off the Use Local Origin in WWMT
  2. Make sure the mesh XForm is reset
  3. Never scale the bones

I was planning to upgrade anyways because I have heard that there were many problems with the skin modifier in 3DS Max 2012. So I was might well I try that after I try Option #1 and your other tips.

Also, I have another question. Why does everytime I export using your exporter, it never keeps the original bones/rig?

http://i.imgur.com/lUjY2cv.png[/t]

Edit:
Does anyone know why Visual C++ 2012 Redistributable takes so long to download? It’s been stuck like this for quite a while.
[t]http://i.imgur.com/WeNne5F.png

Impossible to say without the file. I’ve never once experienced such an issue. But I’m sure if you emailed the Max file to me I’ll figure it out almost instantly.

The installer is just slow. I just leave my office when installing.

Sure, I will send you the files by PM if you want.

I don’t think the installer is slow. It’s been stuck like that for quite a while now. I fear there might be something wrong with the installer.

Edit: Alright, something is definitely wrong because I have been stuck in the same place for hours.

There probably is something wrong if it’s taking hours. I know that it often takes 30+ minutes to install for me, but never hours.

But in regards to the file you sent to me, I was able to export the scene from 3ds Max 2015 with no edits and all the bones/hierarchy/weights are in Source exactly as they are in Max. Here’s a screen shot.

I also tested saving the scene, closing it, re-opening it and re-exporting it. No errors.

Hm. I tried it out using Max 2012. It exported just fine only when it has everything in it. It seems that deleting the vertices will cause the exporter to not detect any bones as if the model had no bones in the first place.
Problem is that is the way I used to create the bodygroups for these models when I used wunderboy’s exporter. So that wouldn’t work.

In regards to that upgrade problem, I guess I hold that for now.

Well if using the WWMT UI, here are some tips:

  • The nodes (mesh and bone) will export that are assigned to the WWMT as parts of the model
  • The bones that are part of the skin modifier of any of the nodes (above) will export
  • For other bones, you need to assign them to the WWMT with the Bones list in the** Models, Attachements & Bones rollout** in the modify tab. (You can also use the Wall Worm > Wall Worm Model Tools > Bone Tools to assign multiple bones at once).

There is some more information on this at Advanced Bone Settings.

There are also bodygroup tools. Unfortunately, the docs and video are out-dated now. I’ll hopefully find time to update them to the docs/video for the current way they work.

As I rarely used wallworm to do the exporting, this will probably take me a while to get use to.

Anyways, I should have elaborate on what I meant bodygroups on my last post.

What I want looks something like this.

http://i.imgur.com/EOzrZyq.png[/t]

In order to achieve that effect, I used UVW XForm in order to utilize alt. textures. For example, like this texture. Although, I still utilized bodygroups.
[t]http://i.imgur.com/ELSy45N.png[/t]

Still I am trying to figure out how other people manage to perfect this method I am trying to use, but I still can’t figure it out. Like this model for example,
[t]http://i.imgur.com/vlEWfMc.png[/t]
[t]http://i.imgur.com/Tmmlhoq.png

Wunderboy has issues exporting skin weights. I use cannonfodder’s exporter which works pretty nicely. (If you’re still using 2012)

Also if you’d prefer to skip a lot of the wallworm setup, you can directly export with wallworm->wallworm exporters-> export smd/dmx then export as a reference smd.

(and for the face you’re better off using flexes)

Problem is they don’t have flexes. And even then it look very weird.
Also another problem is that it doesn’t even give the option for explicit normals at all. So I don’t think I can even use it at all. (Only if Cannonfodder’s exporter itself is used. Wallworm using cannonfodder’s exporter does work though.)

Edit: Turns out I have to bubble in scene for the export settings for Wallworm’s SMD/VTA exporter in order to actually get the bones in.

[editline]19th July 2015[/editline]

Well, I tried using wallworm’s exporter that uses cannonfodder’s compile settings. And I got some interesting results…
Initially at first, the right eye only did work as seen in this picture. (This is when I used Wunderboy’s exporter.)

http://i.imgur.com/8ukoPg7.png[/t]
Now when I used wallworm’s exporter. Now only the left eye still doesn’t work.
[t]http://i.imgur.com/V05X7g4.png

Strange right?

You shouldn’t need explicit normals for the model I don’t think.

I think you’re just setting up bodygroups incorrectly. Mind tossing me the qc to take a look?

From the previous thread I made,

Yes, I need to toggle explicit normals. Otherwise, the normals break and the model end up looking very blocky.

Sure, here it is.


$cd "C:\Users\Dev\Desktop\M-Lopunny"
$cdmaterials "models\pokemon\lopunny"
$modelname "pokemon\gen 4\Mega Lopunny.mdl"
$texturegroup "skinfamilies"
{
	{
		"pm0428_51_BodyA1.vmt"
		"pm0428_51_BodyB1.vmt"
		"pm0428_51_Eye1.vmt"
		"pm0428_51_Mouth1.vmt"
	}
	{
		"pm0428_51_BodyA1_shiny.vmt"
		"pm0428_51_BodyB1_shiny.vmt"
		"pm0428_51_Eye1_shiny.vmt"
		"pm0428_51_Mouth1_shiny.vmt"
	}
}
$bodygroup LEye
{
	studio MLopunnyLEye1.smd
	studio MLopunnyLEye2.smd
	studio MLopunnyLEye3.smd
	studio MLopunnyLEye4.smd
	studio MLopunnyLEye5.smd
	studio MLopunnyLEye6.smd
	studio MLopunnyLEye7.smd
}

$bodygroup REye
{
	studio MLopunnyREye1.smd
	studio MLopunnyREye2.smd
	studio MLopunnyREye3.smd
	studio MLopunnyREye4.smd
	studio MLopunnyREye5.smd
	studio MLopunnyREye6.smd
	studio MLopunnyREye7.smd
}

$bodygroup Mouth
{
	studio MLopunnyMouth1.smd
	studio MLopunnyMouth2.smd
	studio MLopunnyMouth3.smd
	studio MLopunnyMouth4.smd
	studio MLopunnyMouth5.smd
	studio MLopunnyMouth6.smd
}

$surfaceprop "flesh"
$model studio "LopunnyMega.smd"
$sequence ragdoll 	"ragdoll.smd" FPS 30 		activity ACT_DIERAGDOLL 1
$collisionjoints "physics.smd" {

	$mass 60.0
	$inertia 10.00
	$damping 0.01
	$rotdamping 1.50
	$rootbone "Waist"

}





Have you tried fiddling with the bodygroups part of the model tab? could just be hlmv acting dumb.

Yes, I have. The bodygroups do work indeed. It just the skin/bone weights are messed up.

I think it’s your edit mesh modifier. Duplicate the mesh, collapse all, and throw a skinwrap on the duplicate mesh. then set all the values to the lowest they will go and tick weight all points. then hit “convert to skin” and delete the skin wrap modifier.

Then export the duplicate.

–snip–

I should have asked some questions before I do something.
You might want to be a little more specific because I am still quite fuzzy about some parts. What do mean by all the values to the lowest. What is the lowest possible value I can go to? And what settings do I lower the values on? Do you mean the ones in the red outline? Or something else?

Also, what do I with the original mesh when I am actually done editing with the duplicate mesh?

Yeah, the highlighted values should be at the lowest you can go (just drag the slider down till the numbers don’t change, and hit “weight all points” then hit convert to skin and delete the skin wrap modifier.

As for what to do with the original, I suggest hiding it instead of deleting it in case something goes wrong. Then just export it.