Bought Rust a week ago. Still cannot play on Linux

Hi there,

i know this is Early Access and Beta. And I don’t mind bugs in this stage of development. But I would be happy to run the game I bought a week ago at least once! Running on Linux Mint 15 (same as Ubuntu 13.10) the game somehow gets the directory for the libirust-directory wrong and exists with an error:



Fallback handler could not load library /home/comrad/.local/share/Steam/SteamApps/common/rust/rust_Data/Mono/x86_64/.//home/comrad/.local/share/Steam/SteamApps/common/rust/rust_Data/Plugins/x86/liblibrust.so


is there some environmental variable that has to be set to something (xdg…stuff?)?

comrad

I thought this was fixed in the most recent update, Might be a stupid question but I assume you’re all up to date, right?

Thanks for your reply. I’ve updated on steam. Tried the normal and the dev-channel. Removed and uninstalled and reinstalled twice now.

I had a similar missing libs issue.
The slightly dirty and possibly unrelated way I got it running on Linux (ubuntu 64bit, AMD 5450 gfx card I think, it’s an old one) was installing steam in wine, adding a steam app folder that pointed at my existing linux install.
Ran the game under wine (had to update) and then dropped back out and restarted the native linux version.
Switched on beta participation and it started working (gui was a little messed up but playable), one of the updates caused it to fail again so switched off beta participation, (updated again) and it’s been fine since.

thats probably new installs then?

might be some files are missing on new installs?

cause i dont have any issues like that. but my game is installed long time ago… just getting updates

verifying your local content might be good idea

Thanks for all your answers. I’ve verify the local content several times. But good news, everyone. The latest update fixed the issue for me. It works now. Thanks!

I have an other problem with my installation



ERROR: ld.so: object '/home/user/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
Stacktrace:


Native stacktrace:

	/home/user/.local/share/Steam/SteamApps/common/rust/rust_Data/Mono/x86/libmono.so(+0x8b350) [0xf598e350]
	/home/user/.local/share/Steam/SteamApps/common/rust/rust_Data/Mono/x86/libmono.so(+0xbd3ed) [0xf59c03ed]
	[0xf778e410]

Debug info from gdb:

ERROR: ld.so: object '/home/user/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operação não permitida.
No threads.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Preloaded type GtkListStore
Preloaded type GtkWindow
Preloaded type GtkVBox
Preloaded type GtkImage
Preloaded type GtkNotebook
Preloaded type GtkHBox
Preloaded type GtkFrame
Preloaded type GtkAlignment
Preloaded type GtkTreeView
Preloaded type GtkLabel
Preloaded type GtkCheckButton
Preloaded type GtkScrolledWindow
Couldn't find OnScreenSelectorQuit in main module; checking child
Couldn't find OnScreenSelectorOK in main module; checking child
Couldn't find OnScreenSelectorQuit in main module; checking child
Couldn't find OnInputListRowActivated in main module; checking child
exture_compression_s3tc GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_ARB_depth_texture GL_ARB_occlusion_query GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_ATI_envmap_bumpmap GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_NV_depth_clamp GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_NV_primitive_restart GL_ARB_depth_clamp GL_ARB_fragment_program_shadow GL_ARB_half_float_pixel GL_ARB_occlusion_query2 GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_color_buffer_float GL_ARB_pixel_buffer_object GL_ARB_texture_compression_rgtc GL_ARB_texture_float GL_ARB_texture_rectangle GL_EXT_packed_float GL_EXT_pixel_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_rgtc GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_shared_exponent GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_packed_depth_stencil GL_APPLE_object_purgeable GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_gpu_program_parameters GL_EXT_texture_array GL_EXT_texture_integer GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_OES_EGL_image GL_MESA_texture_array GL_ARB_copy_buffer GL_ARB_depth_buffer_float GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_map_buffer_range GL_ARB_texture_rg GL_ARB_texture_swizzle GL_ARB_vertex_array_bgra GL_EXT_separate_shader_objects GL_EXT_texture_swizzle GL_EXT_vertex_array_bgra GL_NV_conditional_render GL_ARB_ES2_compatibility GL_ARB_debug_output GL_ARB_draw_elements_base_vertex GL_ARB_explicit_attrib_location GL_ARB_fragment_coord_conventions GL_ARB_provoking_vertex GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_shader_texture_lod GL_ARB_texture_rgb10_a2ui GL_ARB_vertex_type_2_10_10_10_rev GL_EXT_provoking_vertex GL_EXT_texture_snorm GL_MESA_texture_signed_rgba GL_ARB_get_program_binary GL_ARB_robustness GL_ARB_shader_bit_encoding GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ARB_internalformat_query GL_ARB_texture_storage GL_ARB_invalidate_subdata 
GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_create_context_es2_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event 
Setting maxVSyncInterval to 4
GL: disabling shadows on Intel 9xx (buggy)
GL: disabling framebuffer blit, antialiasing, SRGB on Intel
Total system RAM: 7779 MiB
Initialize engine version: 4.3.1f1 (cebd4d9b5122)


Try to add the path in /etc/ld.so.conf and then run the ldconfig command.
Or you could also set the LD_LIBRARY_PATH variable. Looks like you guys both have basically the same problem. The issue doesn’t exist for me on my Ubuntu 13.10 install but I suspect this is probably related to 64bit vs 32bit somehow

Hi luizrocha13,
I had the same problem on my Ubuntu 13.10 64 bits. Seems like Steam is mixing 32 bits game library with 64 bits system libraries.
I solved the problem with the following two steps:
1 - Disable Steam Community In-Game
2 - Set game launch options as follow: “LD_LIBRARY_PATH=. %command%” (no quotes)