Broken FastDL it used to work

Hello,

I had my FastDL setup, and everything was working. I’ve modded the crap out of Fretta, Prop Hunt, ULX, etc.
Now FastDL is not working and throwing no errors. If I force my fastdl.lua file to throw an error I get nothing. (ex. change woohoo.wav.bz2 to woohoos.wav.bz2 which is not a valid file). My game is not downloading the missing files from the server.
You’ll notice that ULX is throwing an error : “[ULX] ERROR: Tried to add nonexistent or empty file to forced downloads ‘sound/taunts/custom’”
I removed the line: “resource.AddFile( path )” from util.lua, so that error should not be a problem unless I am editing the wrong code. I cannot find “sound/taunts/custom”. I remember writing that string twice, and neither of them change the error output.
In game console will show: “Requesting 4 lua files from the server” No error or anything with this.
Gmod multiplayer settings has “allow all files” and it seems to work on other servers.

“Nav File is wrong or something (4)” How do I fix this? Is it possible? I read you can put the cache file on the fastdl, and then later read in gmod13 that is no longer done. Does it just have to stay there until the end of time? I work to remove all errors in the console…
There is not a single thread/wiki with a clear answer to this. Nav file could also be a map file for the AI…

Also… How do I force a client lua file to wait until LocalPlayer():SteamID() is !nil. Is there a better way to get the local player from a client lua file other then localplayer that does not have this problem? (The problem is that this file is ran before SteamID and/or all entities are initialized)

Any tips or ideas or things I can try? Anything in the console that’s forcing fastdl to just give up?

Links to resources: (You know, the stuff that most people would expect to see when you ask for help)
The server is a dedicated server
Link to FastDL: fastdl.vortexservers.com/tims/fastdl (All files are bzipped. woohoo.wav.bz2)
Server name: “StealthyTurbo’s Prop Hunt”
server IP: 75.127.13.244:27015
fastdl.lua: http://pastebin.com/XRUjBaf0 (location: lua/autorun/server/fastdl.lua)
Console: http://pastebin.com/rHvz7KLj
cfg: sv_downloadurl “http://fastdl.vortexservers.com/tims/fastdl/
server custom taunt file location: Downloads/sound/taunts/custom/file.mp3 (uncompressed not .bz2)

You should probably contact your webhost.

Nothing wrong with the webserver. I’m sure this is a problem with gmod somewhere. Or I’ve overlooked something. For example I can download the following file no with problem. http://fastdl.vortexservers.com/TimS/fastdl/sound/taunts/custom/woohoo.wav.bz2

Can you paste your fastdl file code?

Can you read? I have linked the necessary items at the bottom of my post. If you need more resources I can provide them.

bump

Why be a dick to someone trying to help?

I know how to gmod. I’m asking for help because I actually don’t know why it isn’t working and everything is setup correctly. I’m not a twelve year old who is too lazy to look at the API. I have already spent hours double checking things and trying to figure it out before posting. Getting “Telus Tech support” like answers, is frustrating.
Playing dumb and asking me to post my ‘fastdl.lua’ file when it is already present, linked at the bottom of my post is plain silly and a waste of time for both of us. If anything, I replied to a silly question with a silly answer and if you’re offended maybe next time you’ll notice that I put the most important section in bold.

It almost seems like the server isn’t recognizing that I don’t have the sound files. (sound/taunts/custom/*)
It tries to download maps that I don’t have and the fastdl file prints to the console which means it is running. Any ideas other then “contact your webhost”

  1. Dont be a dick. Despite if you are aggravated. NO ONE will help you if you are.
  2. Are your table downloadables full?
  1. Silly question, silly answer. Wasn’t meant to be a jerk but to say “it’s already there”. If someones that lazy they probably can’t help me anyway?
  2. No error in the console mentioned ‘table downloadables’ Does workshop downloads count towards this limit?
    I have never seen that error pop up at all. (Just for clarification). My entire FastDL not including maps is only 12.7MB. 81 sound files 33 map files and 1 graph file.

Now that workshop had been made faster for downloads etc you should really be using that over FastDL imo.

You can completely ignore this unless you are actually using a script/gamemode that requires nextbot AI.
It just means that there has been no .nav mesh generated for the current map it’s on.

So would you recommend uploading my custom taunts to steam? And is workshop really faster then FastDL? Wouldn’t both be restricted by the same variables ex client and server up/dl speeds. Also, other then maps, which someone should only download 1 at a time anyway. My sounds folder is only 17MB. Speed is practically irrelevant here, but that is good to know. If it works better on steam workshop maybe I should do that instead.

Here what I should do: Use workshop for maps, and use my FastDL for the 12.7MB of custom taunts. Agree? I think uploading the sounds as an addon would be a violation of workshop rules.

Sweet

  1. You’re just being stupid. Tupac is well known, he’s pretty smart as well.

Steam Workshop can now download more than one addon at a time. (max 3 I think?)

Really? I did my research, I put all my resources in my post. I did my part to help you help me so that nobody would have to ask for it because it is just there. It isn’t your job to defend tupac. If he has a problem with me he can PM. Same for you or anyone else. This is off topic and turning into an unnecessary flame war between people I have never heard of or met. I don’t have time for that kind of bs

[editline]2nd March 2016[/editline]

That’s really cool! I have never thought about being able to do that. I’m definitely going to find out if I can upload my taunts now. I really doubt that it would follow the rules though. I would be re-uploading someone else’s work. Even though I chose the sounds and cut/editted some of them myself. Many of the cuts are not mine, nor do I own the rights to where the sounds are derived from.
And isn’t the workshop only for addons?

And that’s why you still don’t have this figured out.


(User was banned for this post ("Don't post if you're not even going to try and help." - Seiteki))

i dont think u do


(User was banned for this post ("Why post?" - Seiteki))

No idea WHY it ever worked in the first place… It works now, no thanks to the 2 trolls above.

Thanks “The_Commander” for your help. It seems the people who actually know stuff is the people who’ve been around for many years. :smiley:

If this is what the gmod forums is like then goood bye! (Of course there are many good people on the forums, I just chose to post on a bad day, and as soon as anyone see’s the word “fastdl” they think: ‘he must be a noob’ and that is completely redonkulous!) I thought the spintires forum was bad, but atleast the community itself is pretty good and it is pretty fun discussing things with them. This forum seems to be full of immature brats. I’m not against children, but people need to either say things that are useful, or nothing at all. Would this rule be effective for me? “Don’t listen to any forum contributor who’s account isn’t atleast 2 years old, they’re probably still learning”.

Percipience is a hypocrite, who interestingly enough is still learning lua, and had no point to posting anything in this thread…

Fix:
I assumed Gmod DS would create all necessary folders. Because the ‘sound’ folder was not auto generating I assumed that I won’t put files there. I put my custom files under ‘downloads’ because that made sense to me. I mean, it makes sense to sync the directories so that it is the same as the FastDL but I thought that didn’t matter because the sound folder was missing on gmod DS. Which also means the resource.AddFile() was also pointing to the wrong but now correct location. BUT resource.AddFile should error “File not found on server” I’m sure I have seen that error before. Ah whatever.