Brush - Do not cast shadows

I have a problem, as the title suggests I would like a brush to not cast shadows, but to receive lighting. I saw there are ways for you to affect a brush in which it affects the way it receives shadows, this is not an ideal option for my scenario though. Thanks.

select the brush -> ctrl + t -> func_brush -> cast shadows: no

Ah, thank you very much.