Bruticus _MAT file Purple Texture Error

I’ve written all of my vmt’s for the usual NormX textures with all of the vtf’s for the NormX and NormY’s. The problem is that the textures still haven’t loaded. I’ve used the same method as doing the .QC and vmt’s for TF3 Megatron and yet it doesn’t work ever since those “RB_…MAT” files showed up in my model viewer:

Typical vmt setting that I used:


"VertexlitGeneric"
{
  "$basetexture" "models/FoC_Combaticons/RB_Bruticus_Chest_TEXSET_Color_NormX"
  "$bumpmap" "models/FoC_Combaticons/RB_Bruticus_Chest_TEXSET_Masks_NormY"
  "$surfaceprop" "metal"
	"$model" 1
	"$phong" "1"
	"$phongexponent" "5"
	"$phongboost" "1.0"	
	"$phongfresnelranges"	"[0 0.5 1]"
	"$halflambert" "1"
	"$phongalbedotint" "1"		
	"$envmapcontrast" "1.0"
	"$envmaptint" "[.3 .3 .3]"
	"$envmapsaturation" "[1 1 1]"
}
"VertexlitGeneric"
{
  "$basetexture" "models/FoC_Combaticons/RB_Bruticus_Chest_TEXSET_Color_NormX_2"
  "$bumpmap" "models/FoC_Combaticons/RB_Bruticus_Chest_TEXSET_Masks_NormY_2"
  "$surfaceprop" "metal"
	"$model" 1
	"$phong" "1"
	"$phongexponent" "5"
	"$phongboost" "1.0"	
	"$phongfresnelranges"	"[0 0.5 1]"
	"$halflambert" "1"
	"$phongalbedotint" "1"		
	"$envmapcontrast" "1.0"
	"$envmaptint" "[.3 .3 .3]"
	"$envmapsaturation" "[1 1 1]"
}

Gonna also show my .QC and SMD files for good measure:


$modelname "FoC_Combaticons/Bruticus.mdl"
$scale 1
$cdmaterials "models/FoC_Combaticons/"
$model Bruticus "Bruticus.SMD"
$texturegroup G2_Bruticus
{
    {
"RB_Bruticus_Chest_TEXSET_Color_NormX.vmt"
"RB_Bruticus_Head_TEXSET_Color_NormX.vmt"
"RB_Bruticus_ArmL_TEXSET_Color_NormX.vmt"
"RB_Bruticus_ArmR_TEXSET_Color_NormX.vmt"
"RB_Bruticus_LegL_TEXSET_Color_NormX.vmt"
"RB_Bruticus_LegR_TEXSET_Color_NormX.vmt"
    }
	{
"RB_Bruticus_Chest_TEXSET_Color_NormX_2.vmt"
"RB_Bruticus_Head_TEXSET_Color_NormX_2.vmt"
"RB_Bruticus_ArmL_TEXSET_Color_NormX_2.vmt"
"RB_Bruticus_ArmR_TEXSET_Color_NormX_2.vmt"
"RB_Bruticus_LegL_TEXSET_Color_NormX_2.vmt"
"RB_Bruticus_LegR_TEXSET_Color_NormX_2.vmt"
    }
}
$surfaceprop "metal"
$sequence idle "Bruticus.SMD" fps 1

$collisionmodel "Bruticus.SMD"{

$mass 100.0
$inertia 1.00
$damping 0.00
$rotdamping 0.00
}

SMD apparent texture names in the file:


RB_BruticusLegR_MAT
138 5.281899 -53.554386 26.596796 0.430832 0.810535 -0.396757 0.551758 0.035645 1 133 1.000000
138 16.563999 -60.301884 25.063396 0.430832 0.810535 -0.396757 0.527344 0.038086 1 133 1.000000
138 13.747399 -60.301884 22.004896 0.430832 0.810535 -0.396757 0.530762 0.030762 1 133 1.000000
RB_BruticusChest_MAT
...

I guess it has something to do with this “RB…MAT” that has popped up since I started using the Skingroup code in the .QC. It probably has something to do with the texture group code in the wrong place maybe?

Right now you’re trying to replace the Color_NormX textures with Color_NormX_2 textures. However, it can’t find the Color_NormX textures. Rename RB_BruticusChest_MAT to RB_Bruticus_Chest_TEXSET_Color_NormX and it should work.

On the SMD file? Because that file goes on and on and on. I’ll see if that works.

Well you can rename it in the SMD file with Notepad’s Replace option, or you can just rename it in your 3D editor and re-export the SMD.

Alright, I think I’m getting a hang of this. So I just rename all of my _MAT codes with the NormX ones?

It worked!

Now all I need to do is add this to his vmt’s and add some color to some vtf’s with gimp and add some phong and he should be done. :smiley: