bsp version 21, expecting 20 map load failed

Hi I am new to creating maps and after compiling my map and try loading it in various valve games I get this in console “bsp version 21, expecting 20 map load failed”. Now I am using Hammer from right clicking source filmmaker launching the sdk and opening hammer from there. Don’t think that would be the issue, but is there anyway of compiling the map so it’s version 20 instead of 21?

EDIT
Things I learned if anyone else is having this issue. Make sure you use the Source SDK to open up hammer. Don’t use hammer in the SFM SDK! That solves the bsp version problems. Other problems I ran into were that some of the skyboxes were not working in source filmmaker. If you pick from the tf2 list you should be ok

https://developer.valvesoftware.com/wiki/Sky_List

. There is also an HDR error you might get when loading your map into SFM so make sure when you compile your map the HDR is checked on!

Also many thanks to Xenon141.

Check the HammerEditor you are using.
Pay attention to the toolbar on the (by default) left edge of the screen.

If it ends with the tool Vertex Manipulator then the problem is not the one I think off.

If it shows some form of a letter M and Y, and by clicking it you see something about exports to Maya…
You are most likely using Source2011 which is made for new-age valve games such as “Alien Swarm” or “Portal 2”.

From the information you provided, I think the problem may be that you are not using the SourceSDK, but a different HammerWorldEditor provided with the SFM (SourceFilmMaker).

For the actual SourceSDK navigate to :
Steam->Library->Tools->SourceSDK.

Although I am not 100% sure, I think you should install the SourceSDK bases aswell.
If however you are using the editor just purely for TeamFortress 2, that may not be required.

Yah the bottom has the vertex manipulator box. Thanks for the quick reply. I am going to try to open hammer via the other way. I am mostly just going to be using Hammer to make maps for my SFM videos.

Ok.

BSP 21 is the modern version however, due to it being able to hold significantly more dynamics and such.
BSP 20 is the current one using in the OrangeBox.

So the only problem I detect must have been you using a newer editor version.

Thanks I tried to compile it from the SDK and it worked inside of CS:S, I have another question I followed this tutorial


and when I loaded the map my skybox was all fuzzy and weird. How do I make it so it shows the skybox I implemented?

The most common error causing that is a “leak”.
Meaning that in your map, the reality can escape to the dark nothingness outside known as “Void”.

Go ahead and find the brush allowing things to escape from the map and patch it up.

Also, if the problem still appears, click “Copy to Clipboard” in the processing window after you are done with a compile and paste the full thing with CTRL+V inhere : http://www.interlopers.net/errors/
I am using the site to solve most of my issues, like light problems and all these.

The second problem that may cause this (If you did not use a 3D skybox) is that the skybox texture you are requesting a compile for is non existant or not in the skybox material directory.

To check for the skybox texture, navigate in hammer:
Tools->Map Settings->WINDOW POPS UP

If the skybox texture is set to something like day_01_xx then that is the default skybox texture and no problems are there, if it is blank I suggest you fill it up with a texture from this list of vanilla ones : https://developer.valvesoftware.com/wiki/Sky_List

PS : I suggest taking a look trough the VDC of Hammer Editor, there are quite some tips and tricks inthere from which you can learn : https://developer.valvesoftware.com/wiki/Category:Level_Design

Thanks a lot! I was using the night one which I guess will only work in half life. I changed it to a counter strike one and it worked! I just tried to open up the map in Source Filmmaker. The skybox doesn’t seem to work in there :/. I am looking up solutions on how to get the skybox to work atm.

I’ll take a look at that site thanks!

The problem with that is that CS:S content is not avieable in TF2 (materials for example).
So you have to port them over.

Yah that makes sense. I am having a hard time trying to get the skyboxes to work inside of Source Filmmaker. I am not to sure if you are familiar with source filmmaker, but I tested out tf2 maps inside of source filmmaker and the skybox seems to work fine in them, but when I implement a tf2 map on the map I am making the skybox is just black.