[BUG] Fast map download glitched out

Ohay !

My problem is pretty simple but I absolutely dunno why it happenned and how I can fix it, here it is:
Whenever I join a server with maps I don’t have, Gmod starts to download the map normally. The DL then jumps suddenly to less than half the process, freezes, and then I get the classic error “Missing map map/“mapname”.bsp, disconnecting.” .

The strange thing is that it just began to fuck up today. It never happened this way before (I ran into the straight “Missing map […] disconnecting” problem, wich was solved by running Steam in administrator mode. In simple words, Gmod wasn’t allowed to download custom maps for some reasons), but now it is like Gmod starts downloading maps, but something is blocking the process.

I checked both my firewall, my antivirus, and it seems they don’t even interact with any Steam related process. I tried to add random lines of code into my config.cfg file and it didn’t work.

Soooo… yeah…

HALP PLZ c:

It’s possibly still something to do with the administrator. First of all, turn off User Account Control in Windows if you still have it on. Did you install any antivirus or security programs recently? And check if the maps folder is set to read only

also try setting sv_maxfilesize to 64

That’s not even a convar. net_maxfilesize doesn’t have any affect on FastDL files either.

Done. It seems it wasn’t the source of the problem.

No, I didn’t. I thinked about it, then checked my program list and my latest downloads and no, nothing related with computer security was downloaded recently.
Also there is a full exception on the C:\programs\steam directory for both my firewall and my antivirus so it can’t be related with them.

Erm. This doesn’t work and I wonder if this command even exists since the console doesn’t recognize it.


Also I noticed the problem was in fact applying to certain servers. I can join some servers normally, in some I will download the map but the download will never finish, on some I will download but the process will be cut as described in the main post, and even on some other servers I will be kicked immediately while trying to download the maps.
Guess what’s weird: I usually go on these servers and it always worked well, until now.

Well a workaround is to search the map on garrysmod.org and put it in the maps folder, if it’s not on garrysmod.org then google it, should be available to download on some website

I did this for some of my favorite servers but I doubt I’ll do it everytime for every server I want to join; I’m looking for a durable solution c:

Bump. Sorry I really need a solution, this is getting very frustrating and now, I don’t know why, but it just kicks me off straight when I want to download a map both on TF2 and Gee Mawd… :suicide:

This is not your problem. It’s the server owner that haven’t put his custom maps onto his FastDL or added them through WorkshopDL so it’s nothing you can do about it.

Try against another server and see if the error still occurs.