[BUG] Garry's Mod Forces DirectX 8.0 + Limited Video Options

After seeing the conversion to SteamPipe and all the issues that are arising, I would’ve probably just given up on fixing this. Needless to say, I’m glad you’re not giving up on us. It must be stressful. Keep it up! And take your time! No need to rush! :downs:
[HR][/HR]
ON TO THE ISSUE:

So I updated to 165, then decided since there was such a big change I’d just uninstall and reinstall Garry’s Mod.
After a clean install, I made sure I had no launch options:

Upon entering the game, my resolution was set to 1280x720 (this was expected for a first time launch) Yet, upon configuring my video settings I noticed some settings were missing. For one the Antialiasing mode only had up to 8x MSAA.

Then when I went to configure the rest, I found that Shadow detail was limited to Low or Medium. Color Correction was also locked at Disabled*.

I took a close look at the settings and found the “culprit”. The DirectX level was set to 8.0. Oddly enough, Before this update I was running on DX9 in Gmod. TF2 currently has no issues with the hardware on DX9.

I’m positive it’s not my “Hardware version”. As an added check, I ran DXWebsetup this morning. My compontents were up to date.

I hope you can figure out what’s going on with Garry’s Mod!
I doubt this will help, but here are my specs! (You never know, compatibility?)
CPU: GeForce GTX 460
CPU: Intel® Core™ i5-3570K CPU @ 3.40GHz
Memory: 8GB Ram
OS: Win 7 64bit

I apologize for the images, but the [spoiler] system is not integrated in this forum and I wanted you to literally see what I’m talking about.

Good luck with your game! :slight_smile:
-jonthedit

Same problem here.

While I’m not personally knowledgeable on the subject, I’d suggest first to ensure that your video adapter drivers are up-to-date. The current drivers from NVidia for the 460 are 320.18 (I have the same card :v:). If that’s all good, you can try to force the DirectX level the game uses to 9 with the startup parameter -dxlevel 90. If that doesn’t work, I’m not entirely sure what else you could do. Maybe someone else knows more.

Also, this forum has its own version of [spoiler]. Use the tags [noparse][sp] and [/sp][/noparse] to hide text. I’m not sure if it works on images, though.

Best of luck with your problem.

That -dxlevel 90 launch command seemed to work for me. I thought I was going crazy when I couldn’t put my settings back to high. Thanks.

For the record, I did eventually try" -dxlevel 90 " in the startup option.
I’m on 320.18 [with the new GeForce experience]
I still have the same issue. I’ll just wait it out, I’m sure garry has his hands full.

The issue was resolved in 13.06.07 Update.

Thanks for fixing this Garry!
I knew you’d come through! :v: