[BUG] Moving to the left and forward (like pressing A&W) can't fix it.

Heya!

Whenever I join Rust (I started playing when it was still open, played for 5 minutes stopped, now trying to get back into it.)
my character keeps moving to the left and forward, exactly like pressing W&A.
This happends to a lot of games and is usually fixed by pressing W&A again.
Not in this case though.
Even when I unplug the keyboard, same.
Tried:

  • Other keyboard
  • Exiting Logitech software
  • Running on Intel HD graphics
  • Uninstalling Unity completely (Even removed registry)
  • Tried Internet Explorer, Chrome, Firefox, Chrome Portable(lol)
  • Removed browser cache

NOTHING, it just keeps doing it.
A buddy of mine tried my account, and he’s fine though, so it’s ‘something’ on my PC.
Can we reinstall Rust?

Help me out people!

Honestly not too sure what to tell you, especially since you said this happens in other games! Perhaps it’s not a software/graphics problem, but a hardware issue (not just your keyboard). I hope for the best though!

If you have a joystick, unplug it, otherwise, try pressing the A&W keys at once,if that doesn’t work, then…restart your machine? Either than that, I have no clue…

There might be a short in your motherboard or the USB plug in your keyboard. If at all possible,
try another keyboard or other USB port in your computer. Preferably if you have both USB2 and 3
ports, try switching to the other.

If you would read the post,you would see he already tried another keyboard.

He stated motherboard. He’s suggesting the same thing as I did. That there is a short somewhere in the computer, not the keyboard, that is misreading any control device he is using.

My bad. I’m obviously too tired to think straight. Or early age dementia. :v:

did you accidentally leave an xbox controller plugged in and and upside down?

It happens :slight_smile:

Just to be clear, it only happends in some games when I bash some buttons while opening lets say the Steam overlay.

This happends to everyone and is fixed by just pressing the same button again.
In Rust, it happends forever as soon as i log in and i cant undo it.

The controller thing might be something though.
In the morning il unplug the Xbox Wirelezz Receiver and uninstall my virtual joystick software for webcam face tracking. (ARMA)

Thanks for the help guys, good community :wink:
Ill go to bed and we will see in the morning

-Wrote this on my Android Phone, holy shit.