Bumpmaps not working?

Not sure what the issue is, or what’s causing this, but bump maps are not showing up in Hammer nor In-Game.
Anyone know the issue/how to fix this?

VTF is showing this

Hammer is showing this

Should be like this

This is what the VMT Looks like.



LightmappedGeneric
{
	"$basetexture"	"medge/plain/blue"
	"$surfaceprop" "plaster"
	"$bumpmap" "medge/plain/brick_normal"
 	"$envmap" "env_cubemap"
	"$envmapcontrast" "1"
	"$normalmapalphaenvmapmask" "1"
}



The VTF isn’t bumpy.

[editline]15th March 2015[/editline]

Also turn down the contrast, 1 us full on.

Turned it down, still not working.

How do you create your bumpmap?

It was from a texture pack.

The vtf you posted is not a bumpmap, its a flat blue surface, probably a regular texture. If you want to know how a bumpmap looks like, google it.
You are either missing the correct bumpmap texture or the vmt is pointing at the wrong file.

This is the bump map for it. I know what a bumpmap looks like.

This is what pack I am trying to use.
Mirror’s Edge Texture Pack

Well, whats the problem now if you have the correct bumpmap for it?

Hammer doesn’t display bumpmaps, but it should work ingame if you got the paths right.

Check the path, it’s probably the path.

The path is perfectly fine.

Can you show a picture of what it looks like for you in-game? The only causes I can think of is that the map has no lighting, or that bump maps are disabled in the game’s render settings.

I tried doing the mat_something ( Cant remember right now ) command in console, also it has lighting.

I copied the vmt and the vtfs, converted them and placed them according to the vmt and the bump worked, try and mess around with it.

What do you mean you converted them. Like remade it?

From the pngs you posted here to vtf.

I second this.

Did you compile lighting? lighting is required for a bump map.

Is this CS:GO? Because i had the same problem 2 days ago.
Bumpmap for one (and only) texture didn’t work although everything was fine (paths) and this texture worked instantly in ep2 mod.

It works now in cSGO too, but no, I have no idea why it’s working now. The only thing I know is that I restarted csgo and steam few times and the texture started to work next day, just like that xD
mat_rebuildallmaterials and all that stuff didn’t worked. I think CSGO can just bug itself, no matter what you do.