Buttons stop working mid-game

I’ve got my buttons working properly (you press it, the barrel spawns), but I’m in the middle of playing, and the button just stops working. I press it, it goes down, but no barrels spawn. I reloaded, still didn’t work, tried again, it worked, then it stopped working again. It seems to randomly work/not work. Anyone know how to fix that?

Buttons have a default delay before they’re able to be pressed again. Is this the problem?

Nope, I set it to one second, so every second I pressed it and it would spawn something, until the button just stopped spawning stuff all together.

No clue whatsoever. I just quickly made a point_template and checked its flags; nothing at all about “stop after a certain number” lol…

Do they always work for you?

I’ve only ever fiddled with them once really, but yeah, I never had any problems. They’re quite common in some of the older build maps; in fact, construct back in v7a had them lol!

What’s v7a? And older builds of what? Also right now I’m using the EP1 engine. Could that be why?

Older build maps. You know, for Garry’s Mod. Maps meant for building.

Okay but he also said “construct back in v7a had them lol”.

Had what? :stuck_out_tongue: Buttons that don’t work very well?

Had point_templates…

oweh.

Yarg, anyone else fiddled with this and encountered problaemos?

and by v7a I mean GMOD v7a (the first version I played lol).

YEah, but has anyone else had this problem?