One of the worst things you can do designing an API, a programming language, a library, probably just any system in general, is provide multiple ways to do the same thing.
This makes things messy and lead to holy wars for no reason. It doesn’t even fucking matter so much if it’s one way or another but people will debate on and on, someone will come up with “a 3rd, best of two worlds” way to do the thing, then 4th, 5th and it’ll only get worse and worse.
It’s good to listen to the community but it’s also important to set strict rules without ambiguity that you yourself follow and make others follow them as well.
UPD: My opinion on the original topic
Maybe call it m_v3fWorldTransformPosition? Or PositionOfTheObjectInSpace? Any nowadays language and IDE supports in-code function/property documentation, seeing an expression like ply.Pos, if it’s super unclear to you what it is because you fell from Moon yesterday you can hover your cursor over ply and the IDE will tell you that it’s an instance of type Player, you can hover over Pos and see something like Vector Pos - Entity position.
Some people prefer typing out whole words, some don’t, but I don’t agree it’s super necessary if it’s still super understandable, and it sure is for Pos, Dir, Rot, ply and so on in the context of game programming.
If you write tons of code you’ll find it annoying using such long variable names and the code will occupy too much horizontal space, requiring wrapping and spacing it across multiple lines when you could’ve avoided it if it was 10 symbols shorter. It’s also sometimes surprisingly harder to visually parse code with long names (even though intuitively you think the opposite) than with reasonably shorter names, so here’s that.