can anyone help me read this script from console

Am i being hacked? whats is this all mean? few days ago i had a problem with my resistance type npcs where they stopped following me and they get spawned in a wrong texture with odd eyeballs. and now I’m trying to read this script and i don’t know what is going on. can someone please tell me if i am being hacked or something? please i need your help asap. thank you.

Error: Material “debug/debuglightmap” uses unknown shader “LightmappedGeneric_dx8”
Error: Material “debug/debugluxels” uses unknown shader “DebugLuxels”
Error: Material “___fillrate_0” uses unknown shader “FillRate”
Error: Material “___debugnormalmap_1” uses unknown shader “DebugNormalMap”
Error: Material “___debugdrawenvmapmask_2” uses unknown shader “DebugDrawEnvmapMask”
Error: Material “___debugdepth_3” uses unknown shader “DebugDepth”
Error: Material “___debugdepth_4” uses unknown shader “DebugDepth”
Initializing Awesomium…
Parent cvar in server.dll not allowed (props_break_max_pieces)
Lua JIT is DISABLED!
Unknown command “cl_thirdperson”
Unknown command “hud_showemptyweaponslots”
JOY_AXIS_X: mapped to Turn (absolute)
JOY_AXIS_Y: mapped to Look (absolute)
JOY_AXIS_Z: unmapped
JOY_AXIS_R: mapped to Forward (absolute)
JOY_AXIS_U: mapped to Side (absolute)
JOY_AXIS_V: unmapped
Advanced Joystick settings initialized
Unknown command “sv_backspeed”
Not playing a local game.

Console initialized.
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
SteamRemoteStorage()->GetPublishedFileDetails failed (3)
PREP OK
Error: Material “___fillrate_0” uses unknown shader “FillRate”
Error: Material “___debugnormalmap_1” uses unknown shader “DebugNormalMap”
Error: Material “___debugdrawenvmapmask_2” uses unknown shader “DebugDrawEnvmapMask”
Error: Material “___debugdepth_3” uses unknown shader “DebugDepth”
Error: Material “___debugdepth_4” uses unknown shader “DebugDepth”
Error: Material “debug/debuglightmap” uses unknown shader “LightmappedGeneric_dx8”
Error: Material “debug/debugluxels” uses unknown shader “DebugLuxels”
Lua JIT is DISABLED!
TEST [maps/rp_city17_build181.bsp][maps/gm_flatgrass.bsp]
TEST [maps/rp_industrial17_v1.bsp][maps/gm_flatgrass.bsp]
Using map cycle file ‘mapcycle.txt’. (‘cfg/mapcycle.txt’ was not found.)
Error: Material “models/humans/female/pupil_r” uses unknown shader “Eyeball”
Error: Material “models/humans/female/pupil_l” uses unknown shader “Eyeball”
Nav File is wrong or something (1)
Garry’s Mod

sandbox
gm_flatgrass
1
76561198135359881
Attemped to precache unknown particle system “plate_green”!
Attemped to precache unknown particle system “generic_smoke”!
Warning: WorldTwoTextureBlend found on a non-displacement surface (material: gm_construct/flatgrass). This wastes perf for no benefit.
Requesting texture value from var “$basetexture” which is not a texture value (material: dev/bloomadd)
Requesting texture value from var “$basetexture” which is not a texture value (material: dev/no_pixel_write)
Requesting texture value from var “$basetexture” which is not a texture value (material: dev/lumcompare)
clientside lua startup!
Lua JIT is DISABLED!
Requesting texture value from var “$dummyvar” which is not a texture value (material: NULL material)
Error: Material “___fillrate_0” uses unknown shader “FillRate”
Error: Material “___debugnormalmap_1” uses unknown shader “DebugNormalMap”
Error: Material “___debugdrawenvmapmask_2” uses unknown shader “DebugDrawEnvmapMask”
Error: Material “___debugdepth_3” uses unknown shader “DebugDepth”
Error: Material “___debugdepth_4” uses unknown shader “DebugDepth”
Error: Material “debug/debuglightmap” uses unknown shader “LightmappedGeneric_dx8”
Error: Material “debug/debugluxels” uses unknown shader “DebugLuxels”
Error: Material “models/humans/female/pupil_r” uses unknown shader “Eyeball”
Error: Material “models/humans/female/pupil_l” uses unknown shader “Eyeball”
Requesting texture value from var “$basetexture” which is not a texture value (material: dev/bloomadd)
Requesting texture value from var “$basetexture” which is not a texture value (material: dev/no_pixel_write)
Requesting texture value from var “$basetexture” which is not a texture value (material: dev/lumcompare)
Achievements disabled: Steam not running.
Achievements disabled, ignoring achievement progress for GMA_PLAY_SINGLEPLAYER
JOY_AXIS_X: mapped to Turn (absolute)
JOY_AXIS_Y: mapped to Look (absolute)
JOY_AXIS_Z: unmapped
JOY_AXIS_R: mapped to Forward (absolute)
JOY_AXIS_U: mapped to Side (absolute)
JOY_AXIS_V: unmapped
Advanced Joystick settings initialized
OnEntityCreated didn’t return a valid entity!
Redownloading all lightmaps
Achievements disabled: Steam not running.
Achievements disabled, ignoring achievement progress for GMA_SPAWNMENUER
Achievements disabled: Steam not running.
Achievements disabled, ignoring achievement progress for GMA_NPCSPAWNER
Achievements disabled: Steam not running.
Achievements disabled, ignoring achievement progress for GMA_SPAWNMENUER
Error: Material “models/police/pupil_r” uses unknown shader “Eyeball”
Error: Material “models/police/pupil_l” uses unknown shader “Eyeball”
Achievements disabled: Steam not running.
Achievements disabled, ignoring achievement progress for GMA_NPCSPAWNER
Achievements disabled: Steam not running.
Achievements disabled, ignoring achievement progress for GMA_SPAWNMENUER
Achievements disabled: Steam not running.
Achievements disabled, ignoring achievement progress for GMA_NPCSPAWNER
Achievements disabled: Steam not running.
Achievements disabled, ignoring achievement progress for GMA_X_STARTUPS
Dropped raviolli from server (Disconnect by user.)
PREP OK
Lua JIT is DISABLED!
TEST [maps/rp_city17_build181.bsp][maps/gm_construct.bsp]
TEST [maps/rp_industrial17_v1.bsp][maps/gm_construct.bsp]
Nav File is wrong or something (4)
Garry’s Mod

sandbox
gm_construct
1
76561198135359881
clientside lua startup!
Lua JIT is DISABLED!
Error: Material “___fillrate_0” uses unknown shader “FillRate”
Error: Material “___debugnormalmap_1” uses unknown shader “DebugNormalMap”
Error: Material “___debugdrawenvmapmask_2” uses unknown shader “DebugDrawEnvmapMask”
Error: Material “___debugdepth_3” uses unknown shader “DebugDepth”
Error: Material “___debugdepth_4” uses unknown shader “DebugDepth”
Error: Material “debug/debuglightmap” uses unknown shader “LightmappedGeneric_dx8”
Error: Material “debug/debugluxels” uses unknown shader “DebugLuxels”
Error: Material “models/humans/female/pupil_r” uses unknown shader “Eyeball”
Error: Material “models/humans/female/pupil_l” uses unknown shader “Eyeball”
Requesting texture value from var “$basetexture” which is not a texture value (material: dev/bloomadd)
Requesting texture value from var “$basetexture” which is not a texture value (material: dev/no_pixel_write)
Requesting texture value from var “$basetexture” which is not a texture value (material: dev/lumcompare)
Error: Material “models/police/pupil_r” uses unknown shader “Eyeball”
Error: Material “models/police/pupil_l” uses unknown shader “Eyeball”
OnEntityCreated didn’t return a valid entity!
Redownloading all lightmaps

Uhh, your best bet is probably to reinstall gmod, it seems like a bunch of files are fucked up. Also make sure you’re not running gmod with directx 8.

yourstalker thank god you replied! omg… i tried to reinstall it but it just won’t work cuz the steam cloud sets everything back to where it was before and i don’t know what to do…do you have any suggestions…?

[editline]21st June 2014[/editline]

@Yourstalker how do i erase Gmod completely from my computer so that i can redownload it as a fresh game? I did the delete local content but it didn’t seem to erase gmod completely from my laptop. how do you erase it completely?

You might just as well try to reinstall Steam as a whole, since GMod can’t even detect if it is running or not. Steam must be running for GMod.

The rest of the errors are normal for OS X and Linux.

No, you are not being hacked.

Forget when he said about DirectX 8, it is only applicable for Windows.

thanks hope it works :frowning:

[editline]21st June 2014[/editline]

Robotboy i did the game cache thing and it says i have one file failed to validate and will be reacquired. but after that i went back to the game and everything is still the same. please help me.

Tell me what the problem EXACTLY is. If you can post screenshots ( upload to http://imgur.com if you do not know how to post ), that would be very helpful.