Can anyone help me set up a linux server?

Title says it all, I’ve been trying to set up a linux server for a long time and I keep running into problems here and there from not running at all to getting a segmentation fault on certain maps or gamemodes.

Here’s my choice of OS’s.



CentOS 4 x86
CentOS 4 32bit	
CentOS 4 x86_64
CentOS 4 64bit	
CentOS 5 /w Kloxo
CentOS 5 32bit with Kloxo(free control panel) preinstalled.	
CentOS 5 /w rtorrent/rutorrent	
CentOS 5 32bit.	
CentOS 5 x86_64
CentOS 5 64bit	
CentOS 6 x86
CentOS 6 32bit	
CentOS 6 x86_64
CentOS 6 64bit	
Debian 4 x86
Debian 4 32bit	
Debian 4 x86_64
Debian 4 64bit	
Debian 5 x86
Debian 5 32bit	
Debian 5 x86_64
Debian 5 64bit	
Debian 6 x86
Debian 6 32bit	
Debian 6 x86_64
Debian 6 64bit	
Fedora 12 x86
Fedora 12 32bit	
Fedora 12 x86_64
Fedora 12 64bit	
Fedora 13 x86
Fedora 13 32bit	
Fedora 13 x86_64
Fedora 13 64bit	
Fedora 14 x86
Fedora 14 32bit	
Fedora 14 x86_64
Fedora 14 64bit	
Suse 11 x86
Suse 11 32bit	
Suse 11 x86_64
Suse 11 64bit	
Ubuntu 10 x86
Ubuntu 10 32bit	
Ubuntu 10 x86_64
Ubuntu 10 64bit	
Ubuntu 11 x86
Ubuntu 11 32bit	
Ubuntu 11 x86_64
Ubuntu 11 64bit	
Ubuntu 9 x86
Ubuntu 9 32bit	
Ubuntu 9 x86_64
Ubuntu 9 64bit


Any help would be ever so much appreciated, cheers guys.

CentOS 6 64bit is working for me, you need to install 32bit libraries, besides that everything worked how it was meant to.

So how do I install these 32-bit libs?

apt-get or aptitude install -y ia32-libs

This is with Debian.

First you need to install everything and run it, when it says you’re missing something do :



yum whatprovides the_library_that_youre_mising


It should tell you name of the package you need, you can then do :



yum install package_name


[editline]24th May 2013[/editline]

Just a side-note, you shouldn’t be running Linux if you don’t know how to use Linux.

Debian 6 x64 = simple, fast & quickly

How else would I learn? Plus, it’s free so I’m not losing anything :zoid:

That’s all well and good, but don’t expect to get any sort of a player-base hosting servers on a OS you’re to familiar with, especially since as Linux servers are currently unstable ( might need Python to confirm this ).

That’s why I asked for help.

This is the error I have been getting:



Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "¯ '°üã
°"
Setting breakpad minidump AppID = 4000
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
PreMinidumpCallback: updating dump comment
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20130525061444_1.dmp
./srcds_run: line 372:  1674 Segmentation fault      $HL_CMD
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Sat May 25 06:14:44 EDT 2013: Server restart in 10 seconds
Sat May 25 06:14:44 EDT 2013: Server Quit


You should probably remove all the bin folders and update only garrysmod. That’s what I usually do in Windows when I get that crap outputted on “Game_srv.so loaded for”.

Thanks, that seems to have worked :wink: