Can not connect to ANY servers for more than 20 seconds......

All I can tell you is I looked at the F1 console and it simply says connection timed out.

How are you launching Rust? And do you have any security software installed?

See thread. Pretty much identical. Started about 2 updates ago. Literally fine one day, broken the next.

http://forum.facepunch.com/showthread.php?t=1437817

[editline]13th January 2015[/editline]

To add to that. Looking in the F1 console the ‘sent messages’ just stops increasing. ‘Tick’ goes to 0/64 and shortly after disconnection occurs.

Another rust update. Still can not stay in a server.

Try a factory reset on your router.

Tried and failed. No internet connectivity problems in ANY other games be they steam based or other…

Without destroying your old one, create a new Windows profile (Control panel > Users). Log into that profile and open Steam as admin and log into your account.

Then, go into the folder Rust is installed to (under Steam) and run, as admin, Rust.exe directly.

Ok I tried that and rust opens but quickly closes.

Try launching in steam as normal?

I tried again launching in my original profile and the test one. Same result in each. Tick falls from 64 to 0 in a moment and I get disconnected.

Still getting kicked out of every server…

I connect and I can’t even move or take out weapons. then after a few seconds I can move but there is extreme lag. My character will not run where I am pointing for example.

Do want to play.

Im experiencing the same issue.

I login to the game, then after a few seconds the game lags and cant move or do anything.

Additionaly, I cant login to the game after restarting the client. I have to restart it multiple times in order to connect. Otherwise, It will hang on something like #Receiving numbers/numbers

Have a look in F1 when you connect and see what is happening to the tick line.

I just found that I can stay in game in idle (not doing anything - ie:walking,hitting with axe -) inside my house).

Once I start doing something then the connection dies. I can still run and hit walls or open inventary but nothing happens. Maybe its a server problem, although I see few players online playing with no issues.

PS: F1 doesnt show anything except,

Interval in timing hit is 0



html: Ignored Enter - coui://html/app/directives/directives.js:11

Tick is: 62-63/64
Server part is all 0 B

Just a heads up, I’m getting similar problems. After playing for 3-30 minutes, I lose connection with the server. Ticks stop coming, network traffic drops, I get “stuck” running, etc. Usually right before this happens the server will go weird. Teammates can see me moving around accurately, but I can’t interact with anything. I can smash a barrel 50 times with the hatchet and it won’t open.

Once the network craps up, ALL internet connectivity drops. Can’t surf the web from any PC on the network. I can correct the problem by cutting power to my FIOS router and letting it cool for about 20 minutes. When it comes back up, I can get a good solid hour of gameplay.

My first inclination was to blame hte crap router. We’ve all had overheating cheap routers before and they’re a PITA. But I do a huge amount of traffic through that router without any problems. Online gaming, torrents, multiple simultaneous video streams (large family), you name it. It only ever craps up when I’m playing Rust.

The network engineer in me is now wondering if Rust is doing something wonky, like resending a ton of unnecessary packets. Maybe someone left a 1ms timeout in some network authentication routine somewhere. There’s something about Rust that makes it the only application capable of crashing my router. I’m going to start a wireshark session next time to see what’s going on.

The issue is ultimately my router, but it’s very strange that this problem only manifests itself while I’m playing Rust.

Blah, nevermind. I just connected to another server and it works well so I guess is the other sh***y server.

The thing is I had this problem a few months back as well. then all of a sudden rust started to work again. Now it’s back to being a problem :frowning: Quite frustrating.