Can only connect to gmod server through 'local network' tab. Not a port forwarding problem.

Ive followed a tutorial from youtube that showed me how to set up the server,
it seemed to have worked (I could connect through local network tab) but no one can join.

I know its not a port forwarding problem, because I’ve forwarded every port (I think) and I cant even connect with “connect 127.0.0.1”,
or by trying to connect to the very same IP listed in the local network tab when you try to connect to it from there.

when i try to connect, or anyone else does they get “failed to connect after 4 tries” or some variant thereof.

Does anyone know of a problem that can cause all connections other than through the local network tab in the client to fail?

for reference (maybe you can see what he left out that caused my problem) here is the video that I followed to get it set up.

Thank you for any help, (and I hope I’ve not made some terrible mistake in my first post on these forums!)

So far i’ve found other people say you have to open different ports (but every one of them has a different secret port you need to open) and someone told me to add sv_lan 0 to my server cfg.

But so far nothing has worked, I’ve uninstalled and reinstalled, watched a lot of tutorials having to do with port forwarding and server installation, but nothing is working.

Ive been working on it for 3 days, and this problem seems intractable…

You aren’t port forwarding correctly. You only need to port forward udp and tcp 27015. You will need to read your routers manual if you don’t know how. Why are you trying to host a server on your computer anyway, that isn’t the greatest idea. If you are just trying to play with friends, they should be able to just join off of you because gmod uses steams p2p networking.

I have all ports between 27000 and 27050 forwarded, but its not working.

I want this so i can get some experience with coding and mapping for a dedicated server, while having my friends over to test it out with me.

okay so far i’ve forwarded all these ports:

1	3840-3840	TCP	192.168.0.101	3840-3840
2	4005-4005	TCP	192.168.0.101	4005-4005
3	4808-4808	TCP	192.168.0.101	4808-4808
4	4810-4810	TCP	192.168.0.101	4810-4810
5	4995-4995	TCP	192.168.0.101	4995-4995
6	7000-7002	TCP	192.168.0.101	7000-7002
7	1234-1237	TCP	192.168.0.101	1234-1237
8	5009-5009	TCP	192.168.0.101	5009-5009
9	1200-1200	UDP	192.168.0.101	1200-1200
11	27020-27020	UDP	192.168.0.101	27020-27020
12	27030-27039	TCP	192.168.0.101	27030-27039
10	27000-27015	Both	192.168.0.101	27000-27015

still no one can connect…

here is the console read out when i boot the server (encase that helps)

http://pastebin.com/wv1VjqJc

why wont this work? im pulling my hair out over this.
At this point i can give up, its become a challenge to get it working now!

Now ive tried adding my computer to the DMZ so that port forwarding shouldn’t have an effect, but it still wont work. No one can join it.

This has to be some problem on THIS side of the fire wall, but i cant find an answer…

[editline]26th February 2017[/editline]

Well i finally found out how to fix it, apparently even though i told windows to open up the windows firewall for it, it didnt.

after checking the windows firewall setting, it had 2 entries for srcd; one open, and one closed.
Opening both fixed the problem, and my server works perfectly now.